Skip to content

← Actionable
Medium, CVSS 6.9amended

Parse Server has a protected fields bypass via LiveQuery subscription WHERE clause

CVE-2026-32098GHSA-j7mm-f4rv-6q6q

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (parse-server 9.6.0-alpha.9, 8.6.35), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm parse-server

    Affected
    >= 9.0.0, < 9.6.0-alpha.9< 8.6.35
    Fixed in
    9.6.0-alpha.9, 8.6.35

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-32098: 0.30% estimated exploitation activity in the next 30 days; percentile 22.78 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact An attacker can exploit LiveQuery subscriptions to infer the values of protected fields without directly receiving them. By subscribing with a WHERE clause that references a protected field (including via dot-notation or $regex), the attacker can observe whether LiveQuery events are delivered for matching objects. This creates a boolean oracle that leaks protected field values. The attack affects any class that has both protectedFields configured in Class-Level Permissions and LiveQuery enabled. Patches The fix adds validation of the LiveQuery subscription WHERE clause against the class's protected fields, mirroring the existing REST API validation. If a subscription's WHERE clause references a protected field directly, via dot-notation, or inside $or / $and / $nor operators, the subscription is rejected with a permission error. This is applied during subscription creation, so existing event delivery paths are not affected. Workarounds Disable LiveQuery for classes that use…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-j7mm-f4rv-6q6q

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-j7mm-f4rv-6q6q

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-32098

Advisory: Parse Server has a protected fields bypass via LiveQuery subscription WHERE clause
IDs: CVE-2026-32098, GHSA-j7mm-f4rv-6q6q
Record: https://patchnext.com/advisories/cve-2026-32098 (revision 3, source checked 26 Oct 2026, 12:43 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: parse-server 9.6.0-alpha.9, 8.6.35. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm parse-server: affected >= 9.0.0, < 9.6.0-alpha.9; < 8.6.35; fixed in 9.6.0-alpha.9, 8.6.35

## Suggested inspection (read-only)
- `npm ls parse-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on parse-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-j7mm-f4rv-6q6q (OSV record GHSA-j7mm-f4rv-6q6q lists affected ranges: npm parse-server >=9.0.0 =0 <8.6.35 (fixed))
- Verified: https://github.com/advisories/GHSA-j7mm-f4rv-6q6q (GitHub-reviewed advisory GHSA-j7mm-f4rv-6q6q lists affected ranges: npm parse-server >=9.0.0 =0 <8.6.35)

Commands are suggestions: review each one before running it.

Loading voting…