Skip to content

← Actionable
Low, CVSS 2.0amended

OpenClaw has cross-account DM pairing authorization bypass via unscoped pairing store access

CVE-2026-32067GHSA-vjp8-wprm-2jw9

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaw 2026.2.26), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm openclaw

    Affected
    <= 2026.2.25
    Fixed in
    2026.2.26

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
2.0 · CVSS:4.0/AV:N/AC:H/AT:P/PR:L/UI:A/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-32067: 0.17% estimated exploitation activity in the next 30 days; percentile 6.04 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary OpenClaw had account-scope gaps in pairing-store access for DM pairing policy, which could let a pairing approval from one account authorize the same sender on another account in multi-account setups. Impact This is an authorization-boundary weakness in multi-account channel deployments. A sender approved in one account could be accepted in another account before explicit approval there. Affected Packages / Versions - Package: openclaw (npm) - Latest published version affected: 2026.2.25 - Vulnerable range: <= 2026.2.25 - Patched version (planned next release): = 2026.2.26 Fix OpenClaw now enforces account-scoped pairing reads/writes consistently across core and extension message channels, with stricter runtime/SDK helpers and shared policy wiring to prevent cross-account pairing bleed. Fix Commit(s) - a0c5e28f3bf0cc0cd9311f9e9ec2ca0352550dcf - bce643a0bd145d3e9cb55400af33bd1b85baeb02 Release Process Note patchedversions is pre-set to the planned next release (2026.2.26).…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-vjp8-wprm-2jw9

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-vjp8-wprm-2jw9

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-32067

Advisory: OpenClaw has cross-account DM pairing authorization bypass via unscoped pairing store access
IDs: CVE-2026-32067, GHSA-vjp8-wprm-2jw9
Record: https://patchnext.com/advisories/cve-2026-32067 (revision 3, source checked 26 Oct 2026, 12:47 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 2.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: openclaw 2026.2.26. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm openclaw: affected <= 2026.2.25; fixed in 2026.2.26

## Suggested inspection (read-only)
- `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on openclaw.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-vjp8-wprm-2jw9 (OSV record GHSA-vjp8-wprm-2jw9 lists affected ranges: npm openclaw >=0 <2026.2.26 (fixed))
- Verified: https://github.com/advisories/GHSA-vjp8-wprm-2jw9 (GitHub-reviewed advisory GHSA-vjp8-wprm-2jw9 lists affected ranges: npm openclaw >=0 <=2026.2.25)

Commands are suggestions: review each one before running it.

Loading voting…