Skip to content

← Actionable
Medium, CVSS 5.7amended

OpenClaw: system.run approval identity mismatch could execute a different binary than displayed

CVE-2026-32065GHSA-hwpq-rrpf-pgcq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaw 2026.2.25), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm openclaw

    Affected
    <= 2026.2.24
    Fixed in
    2026.2.25

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.7 · CVSS:4.0/AV:N/AC:H/AT:P/PR:L/UI:A/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-32065: 0.29% estimated exploitation activity in the next 30 days; percentile 22.21 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary system.run approvals in OpenClaw used rendered command text as the approval identity while trimming argv token whitespace. Runtime execution still used raw argv. A crafted trailing-space executable token could therefore execute a different binary than what the approver saw. Affected Packages / Versions - Package: openclaw (npm) - Affected versions: <= 2026.2.24 - Patched versions: = 2026.2.25 Impact This is an approval-integrity bypass that can lead to unexpected command execution under the OpenClaw runtime user when an attacker can influence command argv and reuse/obtain a matching approval context. Trust Model Note OpenClaw does not treat adversarial multi-user sharing of one gateway host/config as a supported security boundary. This finding is still valid in supported deployments because it breaks the operator approval boundary itself (approved display command vs executed argv). Fix Commit(s) - 03e689fc89bbecbcd02876a95957ef1ad9caa176 Release Process Note patchedversions…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-hwpq-rrpf-pgcq

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-hwpq-rrpf-pgcq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-32065

Advisory: OpenClaw: system.run approval identity mismatch could execute a different binary than displayed
IDs: CVE-2026-32065, GHSA-hwpq-rrpf-pgcq
Record: https://patchnext.com/advisories/cve-2026-32065 (revision 3, source checked 26 Oct 2026, 12:47 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: openclaw 2026.2.25. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm openclaw: affected <= 2026.2.24; fixed in 2026.2.25

## Suggested inspection (read-only)
- `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on openclaw.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-hwpq-rrpf-pgcq (OSV record GHSA-hwpq-rrpf-pgcq lists affected ranges: npm openclaw >=0 <2026.2.25 (fixed))
- Verified: https://github.com/advisories/GHSA-hwpq-rrpf-pgcq (GitHub-reviewed advisory GHSA-hwpq-rrpf-pgcq lists affected ranges: npm openclaw >=0 <=2026.2.24)

Commands are suggestions: review each one before running it.

Loading voting…