Skip to content

← Actionable
High, CVSS 8.7amended

OpenClaw voice-call media stream validated streams after upgrade, which could allow pre-start unauthenticated sockets to increase resource pressure

CVE-2026-32062GHSA-mfg5-7q5g-f37j

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaw 2026.2.22; @openclaw/voice-call 2026.2.22), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-32062: 0.44% estimated exploitation activity in the next 30 days; percentile 38.11 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary @openclaw/voice-call (and the bundled copy shipped in openclaw) accepted media-stream WebSocket upgrades before stream validation. In reachable deployments, unauthenticated pre-start sockets could be held open and increase resource pressure. Affected Packages / Versions - openclaw (npm): vulnerable <= 2026.2.21-2, patched in 2026.2.22. - @openclaw/voice-call (npm): vulnerable <= 2026.2.21, patched in 2026.2.22. Technical Details Before this fix, the voice-call media-stream path upgraded sockets first and ran shouldAcceptStream() after a later start frame. This created a pre-auth window where remote clients could hold idle sockets without call/token validation. Impact Availability risk in deployments where the media-stream endpoint is reachable and streaming is enabled. Under sustained abuse, this could consume connection-related resources and degrade service for legitimate streams. Remediation The fix adds layered controls in the media-stream path: - strict pre-start timeout…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-mfg5-7q5g-f37j

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-mfg5-7q5g-f37j

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-32062

Advisory: OpenClaw voice-call media stream validated streams after upgrade, which could allow pre-start unauthenticated sockets to increase resource pressure
IDs: CVE-2026-32062, GHSA-mfg5-7q5g-f37j
Record: https://patchnext.com/advisories/cve-2026-32062 (revision 3, source checked 26 Oct 2026, 12:53 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: openclaw 2026.2.22; @openclaw/voice-call 2026.2.22. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm openclaw: affected < 2026.2.22; fixed in 2026.2.22
- npm @openclaw/voice-call: affected < 2026.2.22; fixed in 2026.2.22

## Suggested inspection (read-only)
- `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls @openclaw/voice-call --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on openclaw, @openclaw/voice-call.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-mfg5-7q5g-f37j (OSV record GHSA-mfg5-7q5g-f37j lists affected ranges: npm openclaw >=0 =0 <2026.2.22 (fixed))
- Verified: https://github.com/advisories/GHSA-mfg5-7q5g-f37j (GitHub-reviewed advisory GHSA-mfg5-7q5g-f37j lists affected ranges: npm openclaw >=0 =0 <2026.2.22)

Commands are suggestions: review each one before running it.

Loading voting…