Skip to content

← Actionable
Medium, CVSS 6.9amended

OpenClaw vulnerable to arbitrary file read via $include directive

CVE-2026-32061GHSA-56pc-6hvp-4gv4

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaw 2026.2.17), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm openclaw

    Affected
    < 2026.2.17
    Fixed in
    2026.2.17

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.9 · CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-32061: 0.15% estimated exploitation activity in the next 30 days; percentile 4.33 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Vulnerability Path traversal in config $include resolution allowed arbitrary local file reads outside the config directory boundary (CWE-22). Attack Vectors 1. If an attacker can modify OpenClaw config, they can set $include to absolute paths (for example /etc/passwd) and read files accessible to the OpenClaw process. 2. If an attacker can modify OpenClaw config, they can use traversal paths (for example ../../...) to escape the config directory. 3. If an attacker can create symlinks inside the config directory, they can point includes to external files unless real-path checks are enforced. 4. Impact scope is bounded by the file permissions of the OpenClaw runtime user; this is not an unauthenticated remote-only vector by itself. Impact A successful exploit can expose local secrets and credentials readable by the OpenClaw process user, including API keys and private config material. Affected Packages / Versions - Package: openclaw (npm) - Vulnerable versions: <=2026.2.15 - Patched…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-56pc-6hvp-4gv4

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-56pc-6hvp-4gv4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-32061

Advisory: OpenClaw vulnerable to arbitrary file read via $include directive
IDs: CVE-2026-32061, GHSA-56pc-6hvp-4gv4
Record: https://patchnext.com/advisories/cve-2026-32061 (revision 3, source checked 26 Oct 2026, 12:43 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: openclaw 2026.2.17. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm openclaw: affected < 2026.2.17; fixed in 2026.2.17

## Suggested inspection (read-only)
- `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on openclaw.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-56pc-6hvp-4gv4 (OSV record GHSA-56pc-6hvp-4gv4 lists affected ranges: npm openclaw >=0 <2026.2.17 (fixed))
- Verified: https://github.com/advisories/GHSA-56pc-6hvp-4gv4 (GitHub-reviewed advisory GHSA-56pc-6hvp-4gv4 lists affected ranges: npm openclaw >=0 <2026.2.17)

Commands are suggestions: review each one before running it.

Loading voting…