OpenClaw Node system.run approval context-binding weakness in approval-enabled host=node flows
CVE-2026-32058GHSA-hjvp-qhm6-wrh2
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaw 2026.2.26), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm openclaw
- Affected
- < 2026.2.26
- Fixed in
- 2026.2.26
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-hjvp-qhm6-wrh2 lists affected ranges: npm openclaw >=0 <2026.2.26 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-hjvp-qhm6-wrh2 lists affected ranges: npm openclaw >=0 <2026.2.26
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 2.0 · CVSS:4.0/AV:N/AC:H/AT:P/PR:L/UI:A/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-32058: 0.20% estimated exploitation activity in the next 30 days; percentile 9.69 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary In approval-enabled host=node workflows, system.run approvals did not always carry a strict, versioned execution-context binding. In uncommon setups that rely on these approvals as an integrity guardrail, a previously approved request could be reused with changed env input. Affected Packages / Versions - Package: npm openclaw - Latest published npm version at triage: 2026.2.25 - Affected range: <= 2026.2.25 - Planned fixed version (next npm release): 2026.2.26 Preconditions / Typical Exposure This requires all of the following: - system.run usage through host=node - Exec approvals enabled and used as an execution-integrity control - Access to an approval id in the same context Most default single-operator local setups do not rely on this path, so practical exposure is typically lower. Details Approval matching now uses a required versioned binding (systemRunBindingV1) over command argv, cwd, agent/session context, and env hash. The fix: - Requires commandArgv when requesting…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-hjvp-qhm6-wrh2
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-hjvp-qhm6-wrh2
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-32058 Advisory: OpenClaw Node system.run approval context-binding weakness in approval-enabled host=node flows IDs: CVE-2026-32058, GHSA-hjvp-qhm6-wrh2 Record: https://patchnext.com/advisories/cve-2026-32058 (revision 3, source checked 26 Oct 2026, 12:47 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 2.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: openclaw 2026.2.26. A vendor fix does not mean a deployment is fixed. ## Affected components - npm openclaw: affected < 2026.2.26; fixed in 2026.2.26 ## Suggested inspection (read-only) - `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on openclaw. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-hjvp-qhm6-wrh2 (OSV record GHSA-hjvp-qhm6-wrh2 lists affected ranges: npm openclaw >=0 <2026.2.26 (fixed)) - Verified: https://github.com/advisories/GHSA-hjvp-qhm6-wrh2 (GitHub-reviewed advisory GHSA-hjvp-qhm6-wrh2 lists affected ranges: npm openclaw >=0 <2026.2.26) Commands are suggestions: review each one before running it.
Loading voting…