Skip to content

← Actionable
High, CVSS 8.3amended

OpenClaw has gateway plugin auth bypass via encoded dot-segment traversal in protected /api/channels paths

CVE-2026-32036GHSA-mwxv-35wr-4vvj

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaw 2026.2.26), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm openclaw

    Affected
    <= 2026.2.25
    Fixed in
    2026.2.26

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.3 · CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:L/VI:H/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X · score source
EPSS
  • CVE-2026-32036: 0.45% estimated exploitation activity in the next 30 days; percentile 39.10 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Gateway plugin route auth protection for /api/channels could be bypassed using encoded dot-segment traversal (for example ..%2f) in path variants that plugin handlers normalize. Affected Packages / Versions - Package: npm openclaw - Latest published vulnerable version: 2026.2.25 - Vulnerable version range: <= 2026.2.25 - Patched version: 2026.2.26 (planned next release) Impact Under affected versions, crafted alternate paths could bypass gateway auth checks for protected plugin channel routes when plugin handlers decode/canonicalize the incoming path and then route to /api/channels/... handlers. Fix Commit(s) - 258d615c45527ffda37cecd08cd268f97461bde0 Release Process Note patchedversions is pre-set to the planned next release (2026.2.26). After npm publish, maintainers only need to publish the advisory. OpenClaw thanks @zpbrent for reporting.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-mwxv-35wr-4vvj

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-mwxv-35wr-4vvj

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-32036

Advisory: OpenClaw has gateway plugin auth bypass via encoded dot-segment traversal in protected /api/channels paths
IDs: CVE-2026-32036, GHSA-mwxv-35wr-4vvj
Record: https://patchnext.com/advisories/cve-2026-32036 (revision 3, source checked 26 Oct 2026, 12:47 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: openclaw 2026.2.26. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm openclaw: affected <= 2026.2.25; fixed in 2026.2.26

## Suggested inspection (read-only)
- `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on openclaw.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-mwxv-35wr-4vvj (OSV record GHSA-mwxv-35wr-4vvj lists affected ranges: npm openclaw >=0 <2026.2.26 (fixed))
- Verified: https://github.com/advisories/GHSA-mwxv-35wr-4vvj (GitHub-reviewed advisory GHSA-mwxv-35wr-4vvj lists affected ranges: npm openclaw >=0 <=2026.2.25)

Commands are suggestions: review each one before running it.

Loading voting…