OpenClaw has an opt-in insecure Control UI auth over plaintext HTTP could allow privileged access
CVE-2026-32034GHSA-3cvx-236h-m9fj
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaw 2026.2.21), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm openclaw
- Affected
- <= 2026.2.19-2
- Fixed in
- 2026.2.21
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-3cvx-236h-m9fj lists affected ranges: npm openclaw >=0 <2026.2.21 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-3cvx-236h-m9fj lists affected ranges: npm openclaw >=0 <=2026.2.19-2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.9 · CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-32034: 0.40% estimated exploitation activity in the next 30 days; percentile 33.88 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Description In affected releases, when an operator explicitly enabled gateway.controlUi.allowInsecureAuth: true and exposed the gateway over plaintext HTTP, Control UI authentication could permit privileged operator access without the intended device identity + pairing guarantees. This required an insecure deployment choice and credential exposure risk (for example, plaintext transit or prior token leak). It was fixed on main in commit 40a292619e1f2be3a3b1db663d7494c9c2dc0abf (PR #20684). Affected Packages / Versions - Package: openclaw (npm) - Affected published versions: <= 2026.2.19-2 - Planned patched version: 2026.2.21 Impact In these explicitly insecure deployments, an attacker with leaked/intercepted credentials could obtain high-privilege Control UI access. Fix Commit(s) - 40a292619e1f2be3a3b1db663d7494c9c2dc0abf (merged 2026-02-20) OpenClaw thanks @Vasco0x4 for reporting.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-3cvx-236h-m9fj
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-3cvx-236h-m9fj
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-32034 Advisory: OpenClaw has an opt-in insecure Control UI auth over plaintext HTTP could allow privileged access IDs: CVE-2026-32034, GHSA-3cvx-236h-m9fj Record: https://patchnext.com/advisories/cve-2026-32034 (revision 3, source checked 26 Oct 2026, 12:46 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: openclaw 2026.2.21. A vendor fix does not mean a deployment is fixed. ## Affected components - npm openclaw: affected <= 2026.2.19-2; fixed in 2026.2.21 ## Suggested inspection (read-only) - `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on openclaw. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-3cvx-236h-m9fj (OSV record GHSA-3cvx-236h-m9fj lists affected ranges: npm openclaw >=0 <2026.2.21 (fixed)) - Verified: https://github.com/advisories/GHSA-3cvx-236h-m9fj (GitHub-reviewed advisory GHSA-3cvx-236h-m9fj lists affected ranges: npm openclaw >=0 <=2026.2.19-2) Commands are suggestions: review each one before running it.
Loading voting…