OpenClaw has a workspace-only sandbox guard mismatch for @-prefixed absolute paths
CVE-2026-32033GHSA-27cr-4p5m-74rj
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaw 2026.2.24), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm openclaw
- Affected
- <= 2026.2.23
- Fixed in
- 2026.2.24
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-27cr-4p5m-74rj lists affected ranges: npm openclaw >=0 <2026.2.24 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-27cr-4p5m-74rj lists affected ranges: npm openclaw >=0 <=2026.2.23
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.7 · CVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-32033: 0.35% estimated exploitation activity in the next 30 days; percentile 28.50 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A workspace-only file-system guard mismatch allowed @-prefixed absolute paths to bypass boundary validation in some tool path checks. Impact When tools.fs.workspaceOnly=true, certain @-prefixed absolute paths (for example @/etc/passwd) could be validated before canonicalization while runtime path handling normalized the prefix differently. In affected code paths this could permit reads outside the intended workspace boundary. Per SECURITY.md, OpenClaw is primarily a personal-assistant runtime with trusted-user assumptions, and this path is gated behind non-default sandbox/tooling configuration. That reduces practical exposure, but the bypass is still a security bug and is fixed. Affected Packages / Versions - Package: openclaw (npm) - Latest published at triage time: 2026.2.23 - Affected versions: <= 2026.2.23 - Patched versions: = 2026.2.24 Fix Commit(s) - 9ef0fc2ff8fa7b145d1e746d6eb030b1bf692260 OpenClaw thanks @tdjackey for reporting.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-27cr-4p5m-74rj
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-27cr-4p5m-74rj
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-32033 Advisory: OpenClaw has a workspace-only sandbox guard mismatch for @-prefixed absolute paths IDs: CVE-2026-32033, GHSA-27cr-4p5m-74rj Record: https://patchnext.com/advisories/cve-2026-32033 (revision 3, source checked 26 Oct 2026, 12:46 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: openclaw 2026.2.24. A vendor fix does not mean a deployment is fixed. ## Affected components - npm openclaw: affected <= 2026.2.23; fixed in 2026.2.24 ## Suggested inspection (read-only) - `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on openclaw. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-27cr-4p5m-74rj (OSV record GHSA-27cr-4p5m-74rj lists affected ranges: npm openclaw >=0 <2026.2.24 (fixed)) - Verified: https://github.com/advisories/GHSA-27cr-4p5m-74rj (GitHub-reviewed advisory GHSA-27cr-4p5m-74rj lists affected ranges: npm openclaw >=0 <=2026.2.23) Commands are suggestions: review each one before running it.
Loading voting…