Skip to content

← Actionable
High, CVSS 8.7amended

OpenClaw vulnerable to sensitive file disclosure via stageSandboxMedia

CVE-2026-32030GHSA-x9cf-3w63-rpq9

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaw 2026.2.19), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm openclaw

    Affected
    < 2026.2.19
    Fixed in
    2026.2.19

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-32030: 0.36% estimated exploitation activity in the next 30 days; percentile 29.51 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary When iMessage remote attachment fetching is enabled (channels.imessage.remoteHost), stageSandboxMedia accepted arbitrary absolute paths and used SCP to copy them into local staging. If a non-attachment path reaches this flow, files outside expected iMessage attachment directories on the remote host can be staged. Affected Packages / Versions - Package: openclaw - Affected: up to and including 2026.2.17 (latest npm version as of February 19, 2026) - Fixed: pending next release with remote attachment path validation Impact Confidentiality impact. An attacker who can influence inbound attachment path metadata may disclose files readable by the OpenClaw process on the configured remote host. Attack Preconditions 1. iMessage attachments enabled (channels.imessage.includeAttachments=true), and 2. remote attachment mode active (channels.imessage.remoteHost configured or auto-detected), and 3. attacker can inject/tamper with attachment path metadata. Given these preconditions, this…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-x9cf-3w63-rpq9

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-x9cf-3w63-rpq9

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-32030

Advisory: OpenClaw vulnerable to sensitive file disclosure via stageSandboxMedia
IDs: CVE-2026-32030, GHSA-x9cf-3w63-rpq9
Record: https://patchnext.com/advisories/cve-2026-32030 (revision 3, source checked 26 Oct 2026, 12:47 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: openclaw 2026.2.19. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm openclaw: affected < 2026.2.19; fixed in 2026.2.19

## Suggested inspection (read-only)
- `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on openclaw.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-x9cf-3w63-rpq9 (OSV record GHSA-x9cf-3w63-rpq9 lists affected ranges: npm openclaw >=0 <2026.2.19 (fixed))
- Verified: https://github.com/advisories/GHSA-x9cf-3w63-rpq9 (GitHub-reviewed advisory GHSA-x9cf-3w63-rpq9 lists affected ranges: npm openclaw >=0 <2026.2.19)

Commands are suggestions: review each one before running it.

Loading voting…