OpenClaw's browser-origin WebSocket auth hardening gap could enable loopback password brute-force chains
CVE-2026-32025GHSA-jmmg-jqc7-5qf4
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaw 2026.2.25), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm openclaw
- Affected
- <= 2026.2.24
- Fixed in
- 2026.2.25
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-jmmg-jqc7-5qf4 lists affected ranges: npm openclaw >=0 <2026.2.25 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jmmg-jqc7-5qf4 lists affected ranges: npm openclaw >=0 <=2026.2.24
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.7 · CVSS:4.0/AV:L/AC:H/AT:P/PR:L/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-32025: 0.32% estimated exploitation activity in the next 30 days; percentile 25.44 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
This issue is a browser-origin WebSocket auth chain on local loopback deployments using password auth. It is serious, but conditional: an attacker must get the user to open a malicious page and then successfully guess the gateway password. Context and Preconditions OpenClaw’s web/gateway surface is designed for local use and trusted-operator workflows. In affected versions, a browser-origin client could combine three behaviors: - Origin checks not enforced for some non-Control-UI WebSocket client IDs. - Loopback auth attempts exempt from password-failure throttling. - Silent local pairing path available to browser-origin non-Control-UI clients. Successful exploitation requires all of the following: - Gateway reachable on loopback (default). - Password auth mode in use. - Victim opens attacker-controlled web content. - Password is guessable within feasible brute-force/dictionary attempts. Practical Impact If the password is guessed, an attacker can establish an authenticated operator…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-jmmg-jqc7-5qf4
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-jmmg-jqc7-5qf4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-32025 Advisory: OpenClaw's browser-origin WebSocket auth hardening gap could enable loopback password brute-force chains IDs: CVE-2026-32025, GHSA-jmmg-jqc7-5qf4 Record: https://patchnext.com/advisories/cve-2026-32025 (revision 3, source checked 26 Oct 2026, 12:46 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: openclaw 2026.2.25. A vendor fix does not mean a deployment is fixed. ## Affected components - npm openclaw: affected <= 2026.2.24; fixed in 2026.2.25 ## Suggested inspection (read-only) - `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on openclaw. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-jmmg-jqc7-5qf4 (OSV record GHSA-jmmg-jqc7-5qf4 lists affected ranges: npm openclaw >=0 <2026.2.25 (fixed)) - Verified: https://github.com/advisories/GHSA-jmmg-jqc7-5qf4 (GitHub-reviewed advisory GHSA-jmmg-jqc7-5qf4 lists affected ranges: npm openclaw >=0 <=2026.2.24) Commands are suggestions: review each one before running it.
Loading voting…