Skip to content

← Actionable
Medium, CVSS 6.9amended

OpenClaw's dispatch-wrapper depth-cap mismatch can bypass shell-wrapper approval gating in system.run allowlist mode

CVE-2026-32023GHSA-ccg8-46r6-9qgj

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaw 2026.2.24), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm openclaw

    Affected
    <= 2026.2.23
    Fixed in
    2026.2.24

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-32023: 0.29% estimated exploitation activity in the next 30 days; percentile 21.36 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A wrapper-depth parsing mismatch in system.run allowed nested transparent dispatch wrappers (for example repeated /usr/bin/env) to suppress shell-wrapper detection while still matching allowlist resolution. In security=allowlist + ask=on-miss, this could bypass the expected approval prompt for shell execution. Severity / Trust Model OpenClaw’s documented model treats authenticated gateway callers as trusted operators and exec approvals as operator guardrails. This issue is still a real approval-boundary bypass and is triaged as Medium in that model. Technical Details - Dispatch-wrapper unwrapping stopped at MAXDISPATCHWRAPPERDEPTH. - Shell-wrapper extraction could return non-wrapper once depth was exhausted. - Allowlist resolution could still succeed on partially unwrapped argv beginning with /usr/bin/env. - Result: nested wrapper chains could execute /bin/sh -c ... without fresh approval in allowlist + ask=on-miss. Affected Packages / Versions - Package: openclaw (npm) -…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-ccg8-46r6-9qgj

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-ccg8-46r6-9qgj

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-32023

Advisory: OpenClaw's dispatch-wrapper depth-cap mismatch can bypass shell-wrapper approval gating in system.run allowlist mode
IDs: CVE-2026-32023, GHSA-ccg8-46r6-9qgj
Record: https://patchnext.com/advisories/cve-2026-32023 (revision 3, source checked 26 Oct 2026, 12:47 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: openclaw 2026.2.24. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm openclaw: affected <= 2026.2.23; fixed in 2026.2.24

## Suggested inspection (read-only)
- `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on openclaw.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-ccg8-46r6-9qgj (OSV record GHSA-ccg8-46r6-9qgj lists affected ranges: npm openclaw >=0 <2026.2.24 (fixed))
- Verified: https://github.com/advisories/GHSA-ccg8-46r6-9qgj (GitHub-reviewed advisory GHSA-ccg8-46r6-9qgj lists affected ranges: npm openclaw >=0 <=2026.2.23)

Commands are suggestions: review each one before running it.

Loading voting…