Skip to content

← Actionable
Medium, CVSS 5.1amended

OpenClaw safeBins grep -e File Read Bypass (stdin-only policy bypass)

CVE-2026-32022GHSA-3xfw-4pmr-4xc5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaw 2026.2.21), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm openclaw

    Affected
    < 2026.2.21
    Fixed in
    2026.2.21

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.1 · CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-32022: 0.27% estimated exploitation activity in the next 30 days; percentile 19.15 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary OpenClaw tools.exec.safeBins had a stdin-only policy bypass for grep. If pattern input was supplied through -e / --regexp, the validator consumed the pattern as a flag value and still allowed one positional operand. That positional could be a bare filename like .env. Affected Packages / Versions - Package: openclaw (npm) - Latest published vulnerable version: 2026.2.19-2 - Structured vulnerable range: <= 2026.2.19-2 - Planned fixed range for next release: = 2026.2.21 Exploit Preconditions - tools.exec.safeBins must include grep (this is opt-in; grep is not in the default safe-bin list). - An actor must be able to invoke exec tooling under that profile. Technical Details src/infra/exec-safe-bin-policy.ts configured grep with maxPositional: 1 and allowed -e / --regexp value flags. Because -e consumes the pattern in flag-value position, the remaining positional budget could be used for a file operand. Example accepted input in vulnerable builds: That violated the intended…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-3xfw-4pmr-4xc5

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-3xfw-4pmr-4xc5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-32022

Advisory: OpenClaw safeBins grep -e File Read Bypass (stdin-only policy bypass)
IDs: CVE-2026-32022, GHSA-3xfw-4pmr-4xc5
Record: https://patchnext.com/advisories/cve-2026-32022 (revision 3, source checked 26 Oct 2026, 12:53 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: openclaw 2026.2.21. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm openclaw: affected < 2026.2.21; fixed in 2026.2.21

## Suggested inspection (read-only)
- `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on openclaw.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-3xfw-4pmr-4xc5 (OSV record GHSA-3xfw-4pmr-4xc5 lists affected ranges: npm openclaw >=0 <2026.2.21 (fixed))
- Verified: https://github.com/advisories/GHSA-3xfw-4pmr-4xc5 (GitHub-reviewed advisory GHSA-3xfw-4pmr-4xc5 lists affected ranges: npm openclaw >=0 <2026.2.21)

Commands are suggestions: review each one before running it.

Loading voting…