OpenClaw: macOS optional allowlist basename matching could bypass path-based policy
CVE-2026-32016GHSA-7f4q-9rqh-x36p
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaw 2026.2.22), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm openclaw
- Affected
- < 2026.2.22
- Fixed in
- 2026.2.22
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-7f4q-9rqh-x36p lists affected ranges: npm openclaw >=0 <2026.2.22 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7f4q-9rqh-x36p lists affected ranges: npm openclaw >=0 <2026.2.22
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.1 · CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-32016: 0.13% estimated exploitation activity in the next 30 days; percentile 2.34 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary On macOS node-host, optional exec-approval allowlist mode previously treated basename-only entries (for example echo) as trusted command matches. This could allow a same-name local binary (for example ./echo) to run without approval under security=allowlist + ask=on-miss. Scope / Preconditions - macOS node-host path. - Optional exec approvals feature enabled with security=allowlist. - Basename-only allowlist entries configured. Default install posture is not impacted: security=deny by default. Affected Packages / Versions - Package: openclaw (npm) - Latest published npm version at triage time: 2026.2.21-2 - Vulnerable range: <=2026.2.21-2 - Planned patched version (next release): = 2026.2.22 Remediation - Enforced path-only allowlist matching on macOS node-host (basename fallback removed). - Added migration for legacy basename allowlist entries to last-resolved paths when available. - UI/store validation now rejects non-path allowlist patterns. Fix Commit(s) -…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-7f4q-9rqh-x36p
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-7f4q-9rqh-x36p
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-32016 Advisory: OpenClaw: macOS optional allowlist basename matching could bypass path-based policy IDs: CVE-2026-32016, GHSA-7f4q-9rqh-x36p Record: https://patchnext.com/advisories/cve-2026-32016 (revision 3, source checked 26 Oct 2026, 12:47 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: openclaw 2026.2.22. A vendor fix does not mean a deployment is fixed. ## Affected components - npm openclaw: affected < 2026.2.22; fixed in 2026.2.22 ## Suggested inspection (read-only) - `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on openclaw. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-7f4q-9rqh-x36p (OSV record GHSA-7f4q-9rqh-x36p lists affected ranges: npm openclaw >=0 <2026.2.22 (fixed)) - Verified: https://github.com/advisories/GHSA-7f4q-9rqh-x36p (GitHub-reviewed advisory GHSA-7f4q-9rqh-x36p lists affected ranges: npm openclaw >=0 <2026.2.22) Commands are suggestions: review each one before running it.
Loading voting…