Skip to content

← Actionable
High, CVSS 7.3amended

OpenClaw's tools.exec.safeBins PATH-hijack allowed trojan binaries to bypass allowlist checks

CVE-2026-32015GHSA-g75x-8qqm-2vxp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaw 2026.2.19), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm openclaw

    Affected
    >= 2026.1.21, < 2026.2.19
    Fixed in
    2026.2.19

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.3 · CVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-32015: 0.13% estimated exploitation activity in the next 30 days; percentile 2.84 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary tools.exec.safeBins allowlist checks could be bypassed by PATH-hijacked binaries, allowing execution of attacker-controlled trojan binaries under an allowlisted executable name. Affected Packages / Versions - Package: openclaw (npm) - Latest published version at triage time: 2026.2.17 - Affected range: = 2026.1.21 < 2026.2.18 - Patched version: 2026.2.19 Impact In allowlist mode, safeBins validation previously accepted a resolved executable path based on executable name and argument shape, without enforcing trusted executable directories. If an attacker could influence process PATH resolution before gateway startup (or otherwise control the gateway launch environment), a trojan binary with an allowlisted name (for example jq) could be executed. Severity Rationale This issue is rated medium because exploitation requires an additional precondition: influencing the gateway process PATH / launch environment. Request-scoped PATH injection is blocked for host execution. Fix…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-g75x-8qqm-2vxp

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-g75x-8qqm-2vxp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-32015

Advisory: OpenClaw's `tools.exec.safeBins` PATH-hijack allowed trojan binaries to bypass allowlist checks
IDs: CVE-2026-32015, GHSA-g75x-8qqm-2vxp
Record: https://patchnext.com/advisories/cve-2026-32015 (revision 3, source checked 26 Oct 2026, 12:47 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: openclaw 2026.2.19. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm openclaw: affected >= 2026.1.21, < 2026.2.19; fixed in 2026.2.19

## Suggested inspection (read-only)
- `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on openclaw.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-g75x-8qqm-2vxp (OSV record GHSA-g75x-8qqm-2vxp lists affected ranges: npm openclaw >=2026.1.21 <2026.2.19 (fixed))
- Verified: https://github.com/advisories/GHSA-g75x-8qqm-2vxp (GitHub-reviewed advisory GHSA-g75x-8qqm-2vxp lists affected ranges: npm openclaw >=2026.1.21 <2026.2.19)

Commands are suggestions: review each one before running it.

Loading voting…