Skip to content

← Actionable
Medium, CVSS 5.8amended

In OpenClaw, manually adding sort to tools.exec.safeBins could bypass allowlist approval via --compress-program

CVE-2026-32010GHSA-4gc7-qcvf-38wg

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaw 2026.2.22), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm openclaw

    Affected
    <= 2026.2.21-2
    Fixed in
    2026.2.22

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.8 · CVSS:4.0/AV:L/AC:H/AT:P/PR:L/UI:N/VC:N/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-32010: 0.30% estimated exploitation activity in the next 30 days; percentile 22.43 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary This issue applies to a non-default configuration only. If sort is manually added to tools.exec.safeBins, OpenClaw could treat sort --compress-program=<prog as valid safe-bin usage. In security=allowlist + ask=on-miss, this could satisfy allowlist checks and skip operator approval, while GNU sort may invoke an external program via --compress-program. Affected Packages / Versions - Ecosystem: npm - Package: openclaw - Affected: <= 2026.2.21-2 - Patched (planned next release): = 2026.2.22 Default Installations Default installs are not impacted by this specific path because sort is not included in default tools.exec.safeBins. Impact - Type: approval/allowlist bypass in optional safe-bin configuration - Scope: deployments that explicitly include sort in tools.exec.safeBins and use allowlist + ask=on-miss - Consequence: an external program may run under the OpenClaw process context without expected approval Technical Details - sort safe-bin profile allowed --compress-program as a…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-4gc7-qcvf-38wg

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-4gc7-qcvf-38wg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-32010

Advisory: In OpenClaw, manually adding sort to tools.exec.safeBins could bypass allowlist approval via --compress-program
IDs: CVE-2026-32010, GHSA-4gc7-qcvf-38wg
Record: https://patchnext.com/advisories/cve-2026-32010 (revision 3, source checked 26 Oct 2026, 12:47 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: openclaw 2026.2.22. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm openclaw: affected <= 2026.2.21-2; fixed in 2026.2.22

## Suggested inspection (read-only)
- `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on openclaw.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-4gc7-qcvf-38wg (OSV record GHSA-4gc7-qcvf-38wg lists affected ranges: npm openclaw >=0 <2026.2.22 (fixed))
- Verified: https://github.com/advisories/GHSA-4gc7-qcvf-38wg (GitHub-reviewed advisory GHSA-4gc7-qcvf-38wg lists affected ranges: npm openclaw >=0 <=2026.2.21-2)

Commands are suggestions: review each one before running it.

Loading voting…