Skip to content

← Actionable
High, CVSS 7.0amended

OpenClaw: safeBins static default trusted dirs allow writable-dir binary hijack (jq)

CVE-2026-32009GHSA-5gj7-jf77-q2q2

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaw 2026.2.24), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm openclaw

    Affected
    <= 2026.2.23
    Fixed in
    2026.2.24

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.0 · CVSS:4.0/AV:L/AC:H/AT:P/PR:H/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-32009: 0.14% estimated exploitation activity in the next 30 days; percentile 3.24 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary In openclaw<=2026.2.23, safe-bin trust in allowlist mode relied on static default trusted directories that included package-manager paths (notably /opt/homebrew/bin and /usr/local/bin). When a same-name binary (for example jq) is placed in one of those trusted default directories, safe-bin evaluation can be satisfied and execute the attacker-controlled binary. Impact This is an exec allowlist safeBins policy bypass that can lead to command execution in the OpenClaw runtime context. Severity is set to Medium given the required ability to write into trusted host binary directories. Affected Packages / Versions - Package: openclaw (npm) - Vulnerable versions: <= 2026.2.23 - Patched versions: = 2026.2.24 (planned next npm release) - Latest published npm version at triage time (2026-02-24): 2026.2.23 Root Cause - Default safe-bin trusted directories included package-manager/user-managed paths. - Trust decision was directory-membership only for resolved executable paths.…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-5gj7-jf77-q2q2

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-5gj7-jf77-q2q2

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-32009

Advisory: OpenClaw: safeBins static default trusted dirs allow writable-dir binary hijack (`jq`)
IDs: CVE-2026-32009, GHSA-5gj7-jf77-q2q2
Record: https://patchnext.com/advisories/cve-2026-32009 (revision 3, source checked 26 Oct 2026, 12:47 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: openclaw 2026.2.24. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm openclaw: affected <= 2026.2.23; fixed in 2026.2.24

## Suggested inspection (read-only)
- `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on openclaw.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-5gj7-jf77-q2q2 (OSV record GHSA-5gj7-jf77-q2q2 lists affected ranges: npm openclaw >=0 <2026.2.24 (fixed))
- Verified: https://github.com/advisories/GHSA-5gj7-jf77-q2q2 (GitHub-reviewed advisory GHSA-5gj7-jf77-q2q2 lists affected ranges: npm openclaw >=0 <=2026.2.23)

Commands are suggestions: review each one before running it.

Loading voting…