Skip to content

← Actionable
Medium, CVSS 5.3amended

OpenClaw has a BlueBubbles group allowlist mismatch via DM pairing-store fallback

CVE-2026-32006GHSA-25pw-4h6w-qwvm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaw 2026.2.26), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm openclaw

    Affected
    <= 2026.2.25
    Fixed in
    2026.2.26

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-32006: 0.31% estimated exploitation activity in the next 30 days; percentile 23.53 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary In openclaw@2026.2.25, BlueBubbles group authorization could incorrectly treat DM pairing-store identities as group allowlist identities when dmPolicy=pairing and groupPolicy=allowlist. A sender that was only DM-paired (not explicitly present in groupAllowFrom) could pass group sender checks for message and reaction ingress. Per OpenClaw's SECURITY.md trust model, this is a constrained authorization-consistency issue, not a multi-tenant boundary bypass or host-privilege escalation. Affected Packages / Versions - Package: openclaw (npm) - Latest published npm version at triage time: 2026.2.25 - Affected versions: <= 2026.2.25 - Patched versions: = 2026.2.26 (planned next release) Technical Details Root cause was DM/group allowlist composition where DM pairing-store identities could flow into group authorization decisions. Fix approach: - centralize DM/group authorization composition via shared resolvers - remove local DM/group list recomposition at channel callsites - add…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-25pw-4h6w-qwvm

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-25pw-4h6w-qwvm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-32006

Advisory: OpenClaw has a BlueBubbles group allowlist mismatch via DM pairing-store fallback
IDs: CVE-2026-32006, GHSA-25pw-4h6w-qwvm
Record: https://patchnext.com/advisories/cve-2026-32006 (revision 3, source checked 26 Oct 2026, 12:47 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: openclaw 2026.2.26. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm openclaw: affected <= 2026.2.25; fixed in 2026.2.26

## Suggested inspection (read-only)
- `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on openclaw.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-25pw-4h6w-qwvm (OSV record GHSA-25pw-4h6w-qwvm lists affected ranges: npm openclaw >=0 <2026.2.26 (fixed))
- Verified: https://github.com/advisories/GHSA-25pw-4h6w-qwvm (GitHub-reviewed advisory GHSA-25pw-4h6w-qwvm lists affected ranges: npm openclaw >=0 <=2026.2.25)

Commands are suggestions: review each one before running it.

Loading voting…