Skip to content

← Actionable
Medium, CVSS 5.3amended

OpenClaw's Node role device-identity bypass allows unauthorized node.event injection

CVE-2026-32001GHSA-rv2q-f2h5-6xmg

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaw 2026.2.22), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm openclaw

    Affected
    < 2026.2.22
    Fixed in
    2026.2.22

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X · score source
EPSS
  • CVE-2026-32001: 0.28% estimated exploitation activity in the next 30 days; percentile 20.31 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A client authenticated with a shared gateway token could connect as role=node without device identity/pairing, then call node.event to trigger agent.request and voice.transcript flows. Affected Packages / Versions - Package: npm openclaw - Affected versions: <= 2026.2.21-2 - Patched version: 2026.2.22 (planned next release) Details The WebSocket connect path allowed device-less bypass whenever shared auth succeeded. That bypass did not restrict role, so a client could claim role=node with no device identity and still pass handshake auth. Because node.event is node-role allowed, this enabled unauthorized node event injection into agent-trigger flows. Impact Unauthorized node.event injection can trigger agent execution and voice transcript flows for clients that only hold the shared gateway token, without node device pairing. Remediation Upgrade to 2026.2.22 (or newer) once published. The fix requires device identity for role=node connects, even when shared-token auth succeeds.…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-rv2q-f2h5-6xmg

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-rv2q-f2h5-6xmg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-32001

Advisory: OpenClaw's Node role device-identity bypass allows unauthorized node.event injection
IDs: CVE-2026-32001, GHSA-rv2q-f2h5-6xmg
Record: https://patchnext.com/advisories/cve-2026-32001 (revision 3, source checked 26 Oct 2026, 12:46 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: openclaw 2026.2.22. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm openclaw: affected < 2026.2.22; fixed in 2026.2.22

## Suggested inspection (read-only)
- `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on openclaw.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-rv2q-f2h5-6xmg (OSV record GHSA-rv2q-f2h5-6xmg lists affected ranges: npm openclaw >=0 <2026.2.22 (fixed))
- Verified: https://github.com/advisories/GHSA-rv2q-f2h5-6xmg (GitHub-reviewed advisory GHSA-rv2q-f2h5-6xmg lists affected ranges: npm openclaw >=0 <2026.2.22)

Commands are suggestions: review each one before running it.

Loading voting…