Skip to content

← Actionable
High, CVSS 8.6amended

OpenClaw has command injection via Windows shell fallback in Lobster tool execution

CVE-2026-32000GHSA-7fcc-cw49-xm78

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaw 2026.2.19), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm openclaw

    Affected
    < 2026.2.19
    Fixed in
    2026.2.19

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.6 · CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-32000: 0.64% estimated exploitation activity in the next 30 days; percentile 50.85 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The Lobster extension tool execution path used a Windows shell fallback (shell: true) after spawn failures (EINVAL/ENOENT). In that fallback path, shell metacharacters in command arguments can be interpreted by the shell, enabling command injection. Affected Packages / Versions - Package: openclaw (npm) - Affected versions: <= 2026.2.17 - Latest confirmed affected published version: 2026.2.17 - Patched version: 2026.2.19 Technical Details In affected releases (including v2026.2.17), extensions/lobster/src/lobster-tool.ts retried subprocess launch with shell: true on Windows for EINVAL/ENOENT spawn errors. The fix removes shell fallback and resolves Windows wrappers to explicit executable/script argv execution. Fix Commit(s) - ba7be018da354ea9f803ed356d20464df0437916 OpenClaw thanks @allsmog for reporting.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-7fcc-cw49-xm78

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-7fcc-cw49-xm78

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-32000

Advisory: OpenClaw has command injection via Windows shell fallback in Lobster tool execution
IDs: CVE-2026-32000, GHSA-7fcc-cw49-xm78
Record: https://patchnext.com/advisories/cve-2026-32000 (revision 3, source checked 26 Oct 2026, 12:46 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: openclaw 2026.2.19. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm openclaw: affected < 2026.2.19; fixed in 2026.2.19

## Suggested inspection (read-only)
- `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on openclaw.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-7fcc-cw49-xm78 (OSV record GHSA-7fcc-cw49-xm78 lists affected ranges: npm openclaw >=0 <2026.2.19 (fixed))
- Verified: https://github.com/advisories/GHSA-7fcc-cw49-xm78 (GitHub-reviewed advisory GHSA-7fcc-cw49-xm78 lists affected ranges: npm openclaw >=0 <2026.2.19)

Commands are suggestions: review each one before running it.

Loading voting…