Skip to content

← Actionable
Low, CVSS 3.6amended

OpenClaw safeBins stdin-only bypass via sort output and recursive grep flags

CVE-2026-31996GHSA-4685-c5cp-vp95

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaw 2026.2.19), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm openclaw

    Affected
    <= 2026.2.17
    Fixed in
    2026.2.19

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
3.6 · CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:N
EPSS
  • CVE-2026-31996: 0.14% estimated exploitation activity in the next 30 days; percentile 3.78 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary tools.exec.safeBins could be bypassed for filesystem access when sort output flags (-o / --output) or recursive grep flags were allowed through safe-bin execution paths. Affected Packages / Versions - Package: openclaw (npm) - Affected versions: <= 2026.2.17 - Patched versions: = 2026.2.19 - Latest published version at triage time: 2026.2.17 Impact In deployments that enabled tools.exec.safeBins, an attacker with access to command execution flows could turn intended stdin-only safe-bin usage into file writes (sort -o) or recursive file reads (grep -R). Fix Commit(s) - 2c05cbb43e48ebad03626d3125746fb1b9a8520f Found using MCPwner Thanks @nedlir for reporting.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-4685-c5cp-vp95

  2. Revision 1 · created ·

    Published from osv record GHSA-4685-c5cp-vp95

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-31996

Advisory: OpenClaw safeBins stdin-only bypass via sort output and recursive grep flags
IDs: CVE-2026-31996, GHSA-4685-c5cp-vp95
Record: https://patchnext.com/advisories/cve-2026-31996 (revision 2, source checked 26 Oct 2026, 12:46 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 3.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: openclaw 2026.2.19. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm openclaw: affected <= 2026.2.17; fixed in 2026.2.19

## Suggested inspection (read-only)
- `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on openclaw.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-4685-c5cp-vp95 (OSV record GHSA-4685-c5cp-vp95 lists affected ranges: npm openclaw >=0 <2026.2.19 (fixed))
- Verified: https://github.com/advisories/GHSA-4685-c5cp-vp95 (GitHub-reviewed advisory GHSA-4685-c5cp-vp95 lists affected ranges: npm openclaw >=0 <=2026.2.17)

Commands are suggestions: review each one before running it.

Loading voting…