Skip to content

← Actionable
Medium, CVSS 5.1amended

OpenClaw has Windows Lobster shell fallback command injection in constrained fallback path

CVE-2026-31995GHSA-fg3m-vhrr-8gj6

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaw 2026.2.19), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm openclaw

    Affected
    >= 2026.1.21, <= 2026.2.17
    Fixed in
    2026.2.19

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.1 · CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-31995: 0.55% estimated exploitation activity in the next 30 days; percentile 45.82 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary On Windows, the Lobster extension previously retried certain spawn failures (ENOENT/EINVAL) with shell: true for wrapper compatibility. In that fallback path, tool-provided arguments could be interpreted by cmd.exe if fallback was triggered. Affected Packages / Versions - Package: openclaw (npm) - Latest published version at triage: 2026.2.17 - Affected range: = 2026.1.21 <= 2026.2.17 - Patched version: 2026.2.19 (pre-set for next release) Fix The Windows shell fallback was removed. Wrapper compatibility is preserved by resolving .cmd/.bat shims to a concrete Node entrypoint (or executable) and executing with explicit argv (no shell). If a safe entrypoint cannot be resolved, execution now fails closed with a guided error. Fix Commit(s) - ba7be018da354ea9f803ed356d20464df0437916 Severity Context This issue requires Windows plus fallback-triggering conditions, and argument control through a local operator-defined workflow. OpenClaw thanks @tdjackey for reporting.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-fg3m-vhrr-8gj6

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-fg3m-vhrr-8gj6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-31995

Advisory: OpenClaw has Windows Lobster shell fallback command injection in constrained fallback path
IDs: CVE-2026-31995, GHSA-fg3m-vhrr-8gj6
Record: https://patchnext.com/advisories/cve-2026-31995 (revision 3, source checked 26 Oct 2026, 12:46 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: openclaw 2026.2.19. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm openclaw: affected >= 2026.1.21, <= 2026.2.17; fixed in 2026.2.19

## Suggested inspection (read-only)
- `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on openclaw.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-fg3m-vhrr-8gj6 (OSV record GHSA-fg3m-vhrr-8gj6 lists affected ranges: npm openclaw >=2026.1.21 <2026.2.19 (fixed))
- Verified: https://github.com/advisories/GHSA-fg3m-vhrr-8gj6 (GitHub-reviewed advisory GHSA-fg3m-vhrr-8gj6 lists affected ranges: npm openclaw >=2026.1.21 <=2026.2.17)

Commands are suggestions: review each one before running it.

Loading voting…