OpenClaw macOS companion app (beta): allowlist parsing mismatch for system.run shell chains
CVE-2026-31993GHSA-5f9p-f3w2-fwch
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaw 2026.2.22), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm openclaw
- Affected
- < 2026.2.22
- Fixed in
- 2026.2.22
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-5f9p-f3w2-fwch lists affected ranges: npm openclaw >=0 <2026.2.22 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5f9p-f3w2-fwch lists affected ranges: npm openclaw >=0 <2026.2.22
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 2.3 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:L/VA:N/SC:N/SI:L/SA:N · score source
- EPSS
- CVE-2026-31993: 0.30% estimated exploitation activity in the next 30 days; percentile 23.12 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary In the macOS companion app (currently beta), a parsing mismatch in exec approvals could let shell-chain payloads pass allowlist checks in system.run under specific settings. Impact This path requires all of the following: - authenticated caller with operator.write - paired macOS beta node host - exec approvals set to security=allowlist and ask=on-miss Under those conditions, a shell-chain command could be approved from an incomplete command view and then executed on the paired macOS host. Default Install Status Default installs are not affected. Affected Packages / Versions - Package: openclaw (npm) - Affected: <= 2026.2.21-2 - Patched (planned next release): = 2026.2.22 Technical Details The fix hardens macOS allowlist resolution by evaluating shell chains per segment and failing closed on unsafe shell-substitution parsing in allowlist mode. Product Status Note The affected macOS companion app path is currently in beta. Fix Commit(s) -…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-5f9p-f3w2-fwch
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-5f9p-f3w2-fwch
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-31993 Advisory: OpenClaw macOS companion app (beta): allowlist parsing mismatch for system.run shell chains IDs: CVE-2026-31993, GHSA-5f9p-f3w2-fwch Record: https://patchnext.com/advisories/cve-2026-31993 (revision 3, source checked 26 Oct 2026, 12:46 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 2.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: openclaw 2026.2.22. A vendor fix does not mean a deployment is fixed. ## Affected components - npm openclaw: affected < 2026.2.22; fixed in 2026.2.22 ## Suggested inspection (read-only) - `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on openclaw. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-5f9p-f3w2-fwch (OSV record GHSA-5f9p-f3w2-fwch lists affected ranges: npm openclaw >=0 <2026.2.22 (fixed)) - Verified: https://github.com/advisories/GHSA-5f9p-f3w2-fwch (GitHub-reviewed advisory GHSA-5f9p-f3w2-fwch lists affected ranges: npm openclaw >=0 <2026.2.22) Commands are suggestions: review each one before running it.
Loading voting…