Tornado is vulnerable to DoS due to too many multipart parts
CVE-2026-31958GHSA-qjxf-f2mg-c6mc
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (tornado 6.5.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI tornado
- Affected
- <= 6.5.4
- Fixed in
- 6.5.5
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-qjxf-f2mg-c6mc lists affected ranges: PyPI tornado >=0 <6.5.5 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-qjxf-f2mg-c6mc lists affected ranges: PyPI tornado >=0 <=6.5.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-31958: 0.39% estimated exploitation activity in the next 30 days; percentile 33.15 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
In versions of Tornado prior to 6.5.5, the only limit on the number of parts in multipart/form-data is the maxbodysize setting (default 100MB). Since parsing occurs synchronously on the main thread, this creates the possibility of denial-of-service due to the cost of parsing very large multipart bodies with many parts. Tornado 6.5.5 introduces new limits on the size and complexity of multipart bodies, including a default limit of 100 parts per request. These limits are configurable if needed; see tornado.httputil.ParseMultipartConfig. It is also now possible to disable multipart/form-data parsing entirely if it is not required for the application.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-qjxf-f2mg-c6mc
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-qjxf-f2mg-c6mc
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-31958 Advisory: Tornado is vulnerable to DoS due to too many multipart parts IDs: CVE-2026-31958, GHSA-qjxf-f2mg-c6mc Record: https://patchnext.com/advisories/cve-2026-31958 (revision 3, source checked 26 Oct 2026, 13:44 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: tornado 6.5.5. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI tornado: affected <= 6.5.4; fixed in 6.5.5 ## Suggested inspection (read-only) - `python -m pip show tornado`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on tornado. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-qjxf-f2mg-c6mc (OSV record GHSA-qjxf-f2mg-c6mc lists affected ranges: PyPI tornado >=0 <6.5.5 (fixed)) - Verified: https://github.com/advisories/GHSA-qjxf-f2mg-c6mc (GitHub-reviewed advisory GHSA-qjxf-f2mg-c6mc lists affected ranges: PyPI tornado >=0 <=6.5.4) Commands are suggestions: review each one before running it.
Loading voting…