Skip to content

← Actionable
Medium, CVSS 6.3amended

Parse Server vulnerable to user enumeration via email verification endpoint

CVE-2026-31901GHSA-w54v-hf9p-8856

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (parse-server 9.6.0-alpha.8, 8.6.34), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm parse-server

    Affected
    >= 9.0.0-alpha.1, < 9.6.0-alpha.8< 8.6.34
    Fixed in
    8.6.34, 9.6.0-alpha.8

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.3 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-31901: 0.25% estimated exploitation activity in the next 30 days; percentile 16.59 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The email verification endpoint (/verificationEmailRequest) returns distinct error responses depending on whether an email address belongs to an existing user, is already verified, or does not exist. An attacker can send requests with different email addresses and observe the error codes to determine which email addresses are registered in the application. This is a user enumeration vulnerability that affects any Parse Server deployment with email verification enabled (verifyUserEmails: true). Patches The fix introduces a new Parse Server option emailVerifySuccessOnInvalidEmail (default: true) that returns a generic success response for all verification email requests, regardless of whether the email address is valid, already verified, or non-existent. This prevents an attacker from distinguishing between these cases. The fix also strengthens the input validation for the related resetPasswordSuccessOnInvalidEmail option, and adds security checks that warn when either…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-w54v-hf9p-8856

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-w54v-hf9p-8856

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-31901

Advisory: Parse Server vulnerable to user enumeration via email verification endpoint
IDs: CVE-2026-31901, GHSA-w54v-hf9p-8856
Record: https://patchnext.com/advisories/cve-2026-31901 (revision 3, source checked 26 Oct 2026, 12:43 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: parse-server 9.6.0-alpha.8, 8.6.34. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm parse-server: affected >= 9.0.0-alpha.1, < 9.6.0-alpha.8; < 8.6.34; fixed in 8.6.34, 9.6.0-alpha.8

## Suggested inspection (read-only)
- `npm ls parse-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on parse-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-w54v-hf9p-8856 (OSV record GHSA-w54v-hf9p-8856 lists affected ranges: npm parse-server >=9.0.0-alpha.1 =0 <8.6.34 (fixed))
- Verified: https://github.com/advisories/GHSA-w54v-hf9p-8856 (GitHub-reviewed advisory GHSA-w54v-hf9p-8856 lists affected ranges: npm parse-server >=9.0.0-alpha.1 =0 <8.6.34)

Commands are suggestions: review each one before running it.

Loading voting…