Skip to content

← Actionable
High, CVSS 8.7amended

Black's vulnerable version parsing leads to RCE in GitHub Action

CVE-2026-31900GHSA-v53h-f6m7-xcgm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (psf/black 26.3.0; black 26.3.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • GitHub Actions psf/black

    Affected
    < 26.3.0
    Fixed in
    26.3.0
  • PyPI black

    Affected
    < 26.3.0
    Fixed in
    26.3.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-31900: 0.49% estimated exploitation activity in the next 30 days; percentile 42.09 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Black provides a GitHub action for formatting code. This action supports an option, usepyproject: true, for reading the version of Black to use from the repository pyproject.toml. A malicious pull request could edit pyproject.toml to use a direct URL reference to a malicious repository. This could lead to arbitrary code execution in the context of the GitHub Action. Attackers could then gain access to secrets or permissions available in the context of the action. Patches Version 26.3.0 fixes this vulnerability by tightening the validation of the version field. Users who use the GitHub Action as psf/black@stable will automatically pick up this update. Workarounds Do not use the usepyproject: true option in the psf/black GitHub Action.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-v53h-f6m7-xcgm

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record PYSEC-2026-2120

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-31900

Advisory: Black's vulnerable version parsing leads to RCE in GitHub Action
IDs: CVE-2026-31900, GHSA-v53h-f6m7-xcgm
Record: https://patchnext.com/advisories/cve-2026-31900 (revision 3, source checked 26 Oct 2026, 17:08 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: psf/black 26.3.0; black 26.3.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- GitHub Actions psf/black: affected < 26.3.0; fixed in 26.3.0
- PyPI black: affected < 26.3.0; fixed in 26.3.0

## Suggested inspection (read-only)
- GitHub Actions psf/black: check the installed version with your package manager.
- `python -m pip show black`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on psf/black, black.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/PYSEC-2026-2120 (OSV record PYSEC-2026-2120 lists affected ranges: PyPI black >=0 <26.3.0 (fixed))
- Verified: https://github.com/advisories/GHSA-v53h-f6m7-xcgm (GitHub-reviewed advisory GHSA-v53h-f6m7-xcgm lists affected ranges: GitHub Actions psf/black >=0 <26.3.0)

Commands are suggestions: review each one before running it.

Loading voting…