Skip to content

← Actionable
High, CVSS 7.7

Cockpit CMS has SQL Injection in MongoLite Aggregation Optimizer via toJsonExtractRaw()

CVE-2026-31891GHSA-7x5c-vfhj-9628

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (cockpit-hq/cockpit 2.13.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.7 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N
EPSS
  • CVE-2026-31891: 0.40% estimated exploitation activity in the next 30 days; percentile 34.73 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact This is a SQL Injection vulnerability in the MongoLite Aggregation Optimizer. Any Cockpit CMS instance running version 2.13.4 or earlier with API access enabled is potentially affected. Who is impacted: - Any deployment where the /api/content/aggregate/{model} endpoint is publicly accessible or reachable by untrusted users. - Attackers in possession of a valid read-only API key (the lowest privilege level) can exploit this vulnerability — no admin access is required. What an attacker can do: - Inject arbitrary SQL via unsanitized field names in aggregation queries. - Bypass the state=1 published-content filter to access unpublished or restricted content. - Extract unauthorized data from the underlying SQLite content database. Confidentiality impact is High. Integrity and availability are not directly affected by this vulnerability. Patches This vulnerability has been patched in version 2.13.5. All users running Cockpit CMS version 2.13.4 or earlier are strongly advised to…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-7x5c-vfhj-9628

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-31891

Advisory: Cockpit CMS has SQL Injection in MongoLite Aggregation Optimizer via toJsonExtractRaw()
IDs: CVE-2026-31891, GHSA-7x5c-vfhj-9628
Record: https://patchnext.com/advisories/cve-2026-31891 (revision 1, source checked 26 Oct 2026, 14:38 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: cockpit-hq/cockpit 2.13.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist cockpit-hq/cockpit: affected < 2.13.5; fixed in 2.13.5

## Suggested inspection (read-only)
- Packagist cockpit-hq/cockpit: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on cockpit-hq/cockpit.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-7x5c-vfhj-9628 (GitHub-reviewed advisory GHSA-7x5c-vfhj-9628 lists affected ranges: Packagist cockpit-hq/cockpit >=0 <2.13.5)

Commands are suggestions: review each one before running it.

Loading voting…