Shopware vulnerable to a potential take over of app credentials
CVE-2026-31889GHSA-c4p7-rwrg-pf6p
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (shopware/core 6.7.8.1, 6.6.10.15; shopware/platform 6.7.8.1, 6.6.10.15), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist shopware/core
- Affected
- >= 6.7.0.0, < 6.7.8.1< 6.6.10.15
- Fixed in
- 6.6.10.15, 6.7.8.1
Packagist shopware/platform
- Affected
- >= 6.7.0.0, < 6.7.8.1< 6.6.10.15
- Fixed in
- 6.6.10.15, 6.7.8.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-c4p7-rwrg-pf6p lists affected ranges: Packagist shopware/platform >=6.7.0.0 =0 =6.7.0.0 =0 <6.6.10.15
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:L
- EPSS
- CVE-2026-31889: 0.28% estimated exploitation activity in the next 30 days; percentile 20.34 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary We identified and fixed a vulnerability in the Shopware app registration flow that could, under specific conditions, allow attackers to take over the communication channel between a shop and an app. By abusing app re‑registration, an attacker could redirect app traffic to an attacker‑controlled domain and potentially obtain API credentials intended for the legitimate shop. We have no evidence that this vulnerability has been exploited. --- Affected Scope - All apps (public and private) that use a registrationUrl in their app manifest and rely on the legacy HMAC‑based registration flow. - Both on‑premise and cloud installations are affected until updated to a fixed Shopware version or protected by the latest Shopware Security Plugin. - Shopware services and first‑party apps using the affected SDKs were reviewed and patched. The vulnerability does not affect core storefront or administration authentication; it is limited to the app system’s registration and re‑registration…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-c4p7-rwrg-pf6p
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-31889 Advisory: Shopware vulnerable to a potential take over of app credentials IDs: CVE-2026-31889, GHSA-c4p7-rwrg-pf6p Record: https://patchnext.com/advisories/cve-2026-31889 (revision 1, source checked 26 Oct 2026, 14:38 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: shopware/core 6.7.8.1, 6.6.10.15; shopware/platform 6.7.8.1, 6.6.10.15. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist shopware/core: affected >= 6.7.0.0, < 6.7.8.1; < 6.6.10.15; fixed in 6.6.10.15, 6.7.8.1 - Packagist shopware/platform: affected >= 6.7.0.0, < 6.7.8.1; < 6.6.10.15; fixed in 6.6.10.15, 6.7.8.1 ## Suggested inspection (read-only) - Packagist shopware/core: check the installed version with your package manager. - Packagist shopware/platform: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on shopware/core, shopware/platform. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-c4p7-rwrg-pf6p (GitHub-reviewed advisory GHSA-c4p7-rwrg-pf6p lists affected ranges: Packagist shopware/platform >=6.7.0.0 =0 =6.7.0.0 =0 <6.6.10.15) Commands are suggestions: review each one before running it.
Loading voting…