Shopware: Unauthenticated data extraction possible through store-api.order endpoint
CVE-2026-31887GHSA-7vvp-j573-5584
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (shopware/core 6.7.8.1, 6.6.10.15; shopware/platform 6.7.8.1, 6.6.10.15), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist shopware/core
- Affected
- >= 6.7.0.0, < 6.7.8.1< 6.6.10.15
- Fixed in
- 6.6.10.15, 6.7.8.1
Packagist shopware/platform
- Affected
- >= 6.7.0.0, < 6.7.8.1< 6.6.10.15
- Fixed in
- 6.6.10.15, 6.7.8.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7vvp-j573-5584 lists affected ranges: Packagist shopware/core >=6.7.0.0 =0 =6.7.0.0 =0 <6.6.10.15
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.9 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:H/SI:N/SA:N · score source
- EPSS
- CVE-2026-31887: 0.25% estimated exploitation activity in the next 30 days; percentile 16.06 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary An insufficient check on the filter types for unauthenticated customers allows access to orders of other customers. This is part of the deepLinkCode support on the store-api.order endpoint. Details Data Exposure Depending on the order payload configuration, attackers may retrieve: - Customer names - Billing address - Shipping address - Email addresses - Ordered products - Order values - Order numbers - Order dates - Payment method information - Shipping method information - More customs, depending on the given associations in the request Security Impact This vulnerability allows: - Unauthorized access to foreign customer order data - Mass enumeration of recent orders - Potential scraping of customer personal information Limitation No limitation, but only orders from the past 30 days are checked for changeable means of payment (unrelated). Impact The code is present since ~2021. Likely every version since then is impacted for every store.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-7vvp-j573-5584
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-31887 Advisory: Shopware: Unauthenticated data extraction possible through store-api.order endpoint IDs: CVE-2026-31887, GHSA-7vvp-j573-5584 Record: https://patchnext.com/advisories/cve-2026-31887 (revision 1, source checked 26 Oct 2026, 14:53 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: shopware/core 6.7.8.1, 6.6.10.15; shopware/platform 6.7.8.1, 6.6.10.15. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist shopware/core: affected >= 6.7.0.0, < 6.7.8.1; < 6.6.10.15; fixed in 6.6.10.15, 6.7.8.1 - Packagist shopware/platform: affected >= 6.7.0.0, < 6.7.8.1; < 6.6.10.15; fixed in 6.6.10.15, 6.7.8.1 ## Suggested inspection (read-only) - Packagist shopware/core: check the installed version with your package manager. - Packagist shopware/platform: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on shopware/core, shopware/platform. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-7vvp-j573-5584 (GitHub-reviewed advisory GHSA-7vvp-j573-5584 lists affected ranges: Packagist shopware/core >=6.7.0.0 =0 =6.7.0.0 =0 <6.6.10.15) Commands are suggestions: review each one before running it.
Loading voting…