Craft Commerce: Potential IDOR in Commerce carts
CVE-2026-31867GHSA-vff3-pqq8-4cpq
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (craftcms/commerce 5.6.0, 4.11.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist craftcms/commerce
- Affected
- >= 5.0.0, < 5.6.0>= 4.0.0, < 4.11.0
- Fixed in
- 5.6.0, 4.11.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vff3-pqq8-4cpq lists affected ranges: Packagist craftcms/commerce >=5.0.0 =4.0.0 <4.11.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.3 · CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:L/VI:N/VA:L/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-31867: 0.29% estimated exploitation activity in the next 30 days; percentile 22.25 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
An Insecure Direct Object Reference (IDOR) vulnerability exists in Craft Commerce’s cart functionality that allows users to hijack any shopping cart by knowing or guessing its 32-character number. This vulnerability enables the takeover of shopping sessions and potential exposure of PII. Vulnerability Details Root Cause The CartController accepts a user-supplied number parameter to load and modify shopping carts. No ownership validation is performed - the code only checks if the order exists and is incomplete, not whether the requester has authorization to access it. --- Attack Scenario Prerequisites - Target Craft Commerce installation with active shopping carts - Knowledge of a victim’s cart number (32-character hex string) Cart Number Acquisition Vectors 1. Referrer Header Leakage: Cart URLs shared externally expose the number 2. Browser History: Accessible on shared/compromised devices 3. Proxy/WAF Logs: Cart numbers logged in URL parameters 4. Social Engineering: Support…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-vff3-pqq8-4cpq
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-31867 Advisory: Craft Commerce: Potential IDOR in Commerce carts IDs: CVE-2026-31867, GHSA-vff3-pqq8-4cpq Record: https://patchnext.com/advisories/cve-2026-31867 (revision 1, source checked 26 Oct 2026, 14:38 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: craftcms/commerce 5.6.0, 4.11.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist craftcms/commerce: affected >= 5.0.0, < 5.6.0; >= 4.0.0, < 4.11.0; fixed in 5.6.0, 4.11.0 ## Suggested inspection (read-only) - Packagist craftcms/commerce: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on craftcms/commerce. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-vff3-pqq8-4cpq (GitHub-reviewed advisory GHSA-vff3-pqq8-4cpq lists affected ranges: Packagist craftcms/commerce >=5.0.0 =4.0.0 <4.11.0) Commands are suggestions: review each one before running it.
Loading voting…