@siteboon/claude-code-ui is Vulnerable to Shell Command Injection in Git Routes
CVE-2026-31861GHSA-7fv4-fmmc-86g2
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@siteboon/claude-code-ui 1.24.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- <= 1.23.0
- Fixed in
- 1.24.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-7fv4-fmmc-86g2 lists affected ranges: npm @siteboon/claude-code-ui >=0 <1.24.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7fv4-fmmc-86g2 lists affected ranges: npm @siteboon/claude-code-ui >=0 <=1.23.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-31861: 6.27% estimated exploitation activity in the next 30 days; percentile 93.59 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Shell Command Injection in User Git Config Endpoint | Field | Value | |-------|-------| | Severity | High | | CVSS 3.1 | 8.8 (High) — when chained with VULN-01 | | CWE | CWE-78: Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection') | | Attack Vector | Network | | Authentication | JWT required (bypassable via VULN-01) | | Affected Files | server/routes/user.js (lines 58-59) | Description The /api/user/git-config endpoint constructs shell commands by interpolating user-supplied gitName and gitEmail values into command strings passed to childprocess.exec(). The input is placed within double quotes and only " is escaped, but backticks ( ), $() command substitution, and \ sequences are all interpreted within double-quoted strings in bash. This allows authenticated attackers to execute arbitrary OS commands via the git configuration endpoint. Root Cause server/routes/user.js lines 58-59: Only " is escaped. However, within double-quoted bash strings, the…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-7fv4-fmmc-86g2
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-7fv4-fmmc-86g2
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-31861 Advisory: @siteboon/claude-code-ui is Vulnerable to Shell Command Injection in Git Routes IDs: CVE-2026-31861, GHSA-7fv4-fmmc-86g2 Record: https://patchnext.com/advisories/cve-2026-31861 (revision 3, source checked 26 Oct 2026, 12:43 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @siteboon/claude-code-ui 1.24.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @siteboon/claude-code-ui: affected <= 1.23.0; fixed in 1.24.0 ## Suggested inspection (read-only) - `npm ls @siteboon/claude-code-ui --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @siteboon/claude-code-ui. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-7fv4-fmmc-86g2 (OSV record GHSA-7fv4-fmmc-86g2 lists affected ranges: npm @siteboon/claude-code-ui >=0 <1.24.0 (fixed)) - Verified: https://github.com/advisories/GHSA-7fv4-fmmc-86g2 (GitHub-reviewed advisory GHSA-7fv4-fmmc-86g2 lists affected ranges: npm @siteboon/claude-code-ui >=0 <=1.23.0) Commands are suggestions: review each one before running it.
Loading voting…