Skip to content

← Actionable
Medium, CVSS 5.3amended

Unhead has XSS bypass in useHeadSafe via attribute name injection and case-sensitive protocol check

CVE-2026-31860GHSA-g5xx-pwrp-g3fv

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (unhead 2.1.11), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm unhead

    Affected
    <= 2.1.10
    Fixed in
    2.1.11

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N · score source
EPSS
  • CVE-2026-31860: 0.27% estimated exploitation activity in the next 30 days; percentile 19.11 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary useHeadSafe() can be bypassed to inject arbitrary HTML attributes, including event handlers, into SSR-rendered <head tags. This is the composable that Nuxt docs recommend for safely handling user-generated content. Details XSS via data- attribute name injection The acceptDataAttrs function (safe.ts, line 16-20) allows any property key starting with data- through to the final HTML. It only checks the prefix, not whether the key contains spaces or other characters that break HTML attribute parsing. This result gets merged into every tag's props at line 114: Then propsToString (propsToString.ts, line 26) interpolates property keys directly into the HTML string with no sanitization: A space in the key breaks out of the attribute name. Everything after the space becomes separate HTML attributes. PoC The most practical vector uses a link tag. <link rel="stylesheet" fires onload once the stylesheet loads, giving reliable script execution: SSR output: The browser parses…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-g5xx-pwrp-g3fv

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-g5xx-pwrp-g3fv

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-31860

Advisory: Unhead has XSS bypass in `useHeadSafe` via attribute name injection and case-sensitive protocol check
IDs: CVE-2026-31860, GHSA-g5xx-pwrp-g3fv
Record: https://patchnext.com/advisories/cve-2026-31860 (revision 3, source checked 26 Oct 2026, 12:46 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: unhead 2.1.11. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm unhead: affected <= 2.1.10; fixed in 2.1.11

## Suggested inspection (read-only)
- `npm ls unhead --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on unhead.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-g5xx-pwrp-g3fv (OSV record GHSA-g5xx-pwrp-g3fv lists affected ranges: npm unhead >=0 <2.1.11 (fixed))
- Verified: https://github.com/advisories/GHSA-g5xx-pwrp-g3fv (GitHub-reviewed advisory GHSA-g5xx-pwrp-g3fv lists affected ranges: npm unhead >=0 <=2.1.10)

Commands are suggestions: review each one before running it.

Loading voting…