Skip to content

← Actionable
Critical, CVSS 9.3amended

Parse Server vulnerable to SQL injection via Increment operation on nested object field in PostgreSQL

CVE-2026-31856GHSA-q3vj-96h2-gwvg

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (parse-server 9.6.0-alpha.3, 8.6.29), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm parse-server

    Affected
    >= 9.0.0-alpha.1, < 9.6.0-alpha.3< 8.6.29
    Fixed in
    9.6.0-alpha.3, 8.6.29

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-31856: 0.44% estimated exploitation activity in the next 30 days; percentile 38.14 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A SQL injection vulnerability exists in the PostgreSQL storage adapter when processing Increment operations on nested object fields using dot notation (e.g., stats.counter). The amount value is interpolated directly into the SQL query without parameterization or type validation. An attacker who can send write requests to the Parse Server REST API can inject arbitrary SQL subqueries to read any data from the database, bypassing CLPs and ACLs. MongoDB deployments are not affected. Patches The fix adds type validation to reject non-number values and parameterizes the value in the SQL query instead of interpolating it. Workarounds There is no known workaround. References - GitHub security advisory: https://github.com/parse-community/parse-server/security/advisories/GHSA-q3vj-96h2-gwvg - Fix Parse Server 9: https://github.com/parse-community/parse-server/releases/tag/9.6.0-alpha.3 - Fix Parse Server 8: https://github.com/parse-community/parse-server/releases/tag/8.6.29

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-q3vj-96h2-gwvg

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GHSA-q3vj-96h2-gwvg

  4. Revision 1 · created ·

    Published from ghsa record GHSA-q3vj-96h2-gwvg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-31856

Advisory: Parse Server vulnerable to SQL injection via `Increment` operation on nested object field in PostgreSQL
IDs: CVE-2026-31856, GHSA-q3vj-96h2-gwvg
Record: https://patchnext.com/advisories/cve-2026-31856 (revision 4, source checked 26 Oct 2026, 12:43 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: parse-server 9.6.0-alpha.3, 8.6.29. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm parse-server: affected >= 9.0.0-alpha.1, < 9.6.0-alpha.3; < 8.6.29; fixed in 9.6.0-alpha.3, 8.6.29

## Suggested inspection (read-only)
- `npm ls parse-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on parse-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-q3vj-96h2-gwvg (GitHub-reviewed advisory GHSA-q3vj-96h2-gwvg lists affected ranges: npm parse-server >=9.0.0-alpha.1 =0 <8.6.29)
- Verified: https://osv.dev/vulnerability/GHSA-q3vj-96h2-gwvg (OSV record GHSA-q3vj-96h2-gwvg lists affected ranges: npm parse-server >=9.0.0-alpha.1 =0 <8.6.29 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…