goodoneuz/pay-uz: the /payment/api/editable/update endpoint overwrites existing PHP payment hook files
CVE-2026-31843GHSA-m5wg-cjgh-223j
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (goodoneuz/pay-uz 3.0.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist goodoneuz/pay-uz
- Affected
- <= 2.2.24
- Fixed in
- 3.0.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-m5wg-cjgh-223j lists affected ranges: Packagist goodoneuz/pay-uz >=0 <=2.2.24
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 10.0 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X · score source
- EPSS
- CVE-2026-31843: 1.38% estimated exploitation activity in the next 30 days; percentile 72.21 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The goodoneuz/pay-uz Laravel package (<= 2.2.24) contains a critical vulnerability in the /payment/api/editable/update endpoint that allows unauthenticated attackers to overwrite existing PHP payment hook files. The endpoint is exposed via Route::any() without authentication middleware, enabling remote access without credentials. User-controlled input is directly written into executable PHP files using fileputcontents(). These files are later executed via require() during normal payment processing workflows, resulting in remote code execution under default application behavior. The payment secret token mentioned by the vendor is unrelated to this endpoint and does not mitigate the vulnerability.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-m5wg-cjgh-223j
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-31843 Advisory: goodoneuz/pay-uz: the /payment/api/editable/update endpoint overwrites existing PHP payment hook files IDs: CVE-2026-31843, GHSA-m5wg-cjgh-223j Record: https://patchnext.com/advisories/cve-2026-31843 (revision 1, source checked 26 Oct 2026, 14:50 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 10.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: goodoneuz/pay-uz 3.0.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist goodoneuz/pay-uz: affected <= 2.2.24; fixed in 3.0.0 ## Suggested inspection (read-only) - Packagist goodoneuz/pay-uz: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on goodoneuz/pay-uz. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-m5wg-cjgh-223j (GitHub-reviewed advisory GHSA-m5wg-cjgh-223j lists affected ranges: Packagist goodoneuz/pay-uz >=0 <=2.2.24) Commands are suggestions: review each one before running it.
Loading voting…