Hyperterse: Raw exposure of database statements in MCP search tool
CVE-2026-31841GHSA-92gp-jfgx-9qpv
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (hyperterse 2.2.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm hyperterse
- Affected
- >= 2.0.0, < 2.2.0
- Fixed in
- 2.2.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-92gp-jfgx-9qpv lists affected ranges: npm hyperterse >=2.0.0 <2.2.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-92gp-jfgx-9qpv lists affected ranges: npm hyperterse >=2.0.0 <2.2.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
- EPSS
- CVE-2026-31841: 0.19% estimated exploitation activity in the next 30 days; percentile 8.21 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Hyperterse allows users to specify database queries for tools to execute under the hood. As of v2.0.0, there are only two tools exposed - search and execute. The search tool allows LLMs to search for tools using natural language. While returning results, Hyperterse also returned the raw SQL queries, exposing statements which were supposed to be executed under the hood, and protected from being displayed publicly. This issue has been fixed as of v2.2.0 and relevant tests to catch these have been added.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-92gp-jfgx-9qpv
- Revision 1 · created ·
Published from osv record GHSA-92gp-jfgx-9qpv
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-31841 Advisory: Hyperterse: Raw exposure of database statements in MCP search tool IDs: CVE-2026-31841, GHSA-92gp-jfgx-9qpv Record: https://patchnext.com/advisories/cve-2026-31841 (revision 2, source checked 26 Oct 2026, 12:46 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: hyperterse 2.2.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm hyperterse: affected >= 2.0.0, < 2.2.0; fixed in 2.2.0 ## Suggested inspection (read-only) - `npm ls hyperterse --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on hyperterse. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-92gp-jfgx-9qpv (OSV record GHSA-92gp-jfgx-9qpv lists affected ranges: npm hyperterse >=2.0.0 <2.2.0 (fixed)) - Verified: https://github.com/advisories/GHSA-92gp-jfgx-9qpv (GitHub-reviewed advisory GHSA-92gp-jfgx-9qpv lists affected ranges: npm hyperterse >=2.0.0 <2.2.0) Commands are suggestions: review each one before running it.
Loading voting…