Skip to content

← Actionable
Critical, CVSS 9.3amended

Parse Server: SQL injection via dot-notation field name in PostgreSQL

CVE-2026-31840GHSA-qpr4-jrj4-6f27

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (parse-server 9.6.0-alpha.2, 8.6.28), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm parse-server

    Affected
    >= 9.0.0, < 9.6.0-alpha.2< 8.6.28
    Fixed in
    9.6.0-alpha.2, 8.6.28

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-31840: 0.43% estimated exploitation activity in the next 30 days; percentile 37.67 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact An attacker can use a dot-notation field name in combination with the sort query parameter to inject SQL into the PostgreSQL database through an improper escaping of sub-field values in dot-notation queries. The vulnerability may also affect queries that use dot-notation field names with the distinct and where query parameters. This vulnerability only affects deployments using a PostgreSQL database. Patches The fix escapes characters in dot-notation sub-field values that could allow a SQL breakout. Workarounds There is no known workaround. References - GitHub security advisory: https://github.com/parse-community/parse-server/security/advisories/GHSA-qpr4-jrj4-6f27 - Fix Parse Server 9: https://github.com/parse-community/parse-server/releases/tag/9.6.0-alpha.2 - Fix Parse Server 8: https://github.com/parse-community/parse-server/releases/tag/8.6.28

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-qpr4-jrj4-6f27

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GHSA-qpr4-jrj4-6f27

  4. Revision 1 · created ·

    Published from ghsa record GHSA-qpr4-jrj4-6f27

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-31840

Advisory: Parse Server: SQL injection via dot-notation field name in PostgreSQL
IDs: CVE-2026-31840, GHSA-qpr4-jrj4-6f27
Record: https://patchnext.com/advisories/cve-2026-31840 (revision 4, source checked 26 Oct 2026, 12:43 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: parse-server 9.6.0-alpha.2, 8.6.28. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm parse-server: affected >= 9.0.0, < 9.6.0-alpha.2; < 8.6.28; fixed in 9.6.0-alpha.2, 8.6.28

## Suggested inspection (read-only)
- `npm ls parse-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on parse-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-qpr4-jrj4-6f27 (GitHub-reviewed advisory GHSA-qpr4-jrj4-6f27 lists affected ranges: npm parse-server >=9.0.0 =0 <8.6.28)
- Verified: https://osv.dev/vulnerability/GHSA-qpr4-jrj4-6f27 (OSV record GHSA-qpr4-jrj4-6f27 lists affected ranges: npm parse-server >=9.0.0 =0 <8.6.28 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…