Parse Server vulnerable to LDAP injection via unsanitized user input in DN and group filter construction
CVE-2026-31828GHSA-7m6r-fhh7-r47c
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (parse-server 9.5.2-alpha.13, 8.6.26), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm parse-server
- Affected
- >= 9.0.0-alpha.1, < 9.5.2-alpha.13< 8.6.26
- Fixed in
- 9.5.2-alpha.13, 8.6.26
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-7m6r-fhh7-r47c lists affected ranges: npm parse-server >=9.0.0-alpha.1 =0 <8.6.26 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7m6r-fhh7-r47c lists affected ranges: npm parse-server >=9.0.0-alpha.1 =0 <8.6.26
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.0 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-31828: 0.45% estimated exploitation activity in the next 30 days; percentile 39.08 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The LDAP authentication adapter is vulnerable to LDAP injection. User-supplied input (authData.id) is interpolated directly into LDAP Distinguished Names (DN) and group search filters without escaping special characters. This allows an attacker with valid LDAP credentials to manipulate the bind DN structure and to bypass group membership checks. This enables privilege escalation from any authenticated LDAP user to a member of any restricted group. The vulnerability affects Parse Server deployments that use the LDAP authentication adapter with group-based access control. Patches The vulnerability is fixed by escaping user input before interpolation into DN strings (per RFC 4514) and LDAP filter strings (per RFC 4515). Workarounds There is no known workaround. References - GitHub security advisory: https://github.com/parse-community/parse-server/security/advisories/GHSA-7m6r-fhh7-r47c - Fix Parse Server 9:…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-7m6r-fhh7-r47c
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-7m6r-fhh7-r47c
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-31828 Advisory: Parse Server vulnerable to LDAP injection via unsanitized user input in DN and group filter construction IDs: CVE-2026-31828, GHSA-7m6r-fhh7-r47c Record: https://patchnext.com/advisories/cve-2026-31828 (revision 3, source checked 26 Oct 2026, 12:43 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: parse-server 9.5.2-alpha.13, 8.6.26. A vendor fix does not mean a deployment is fixed. ## Affected components - npm parse-server: affected >= 9.0.0-alpha.1, < 9.5.2-alpha.13; < 8.6.26; fixed in 9.5.2-alpha.13, 8.6.26 ## Suggested inspection (read-only) - `npm ls parse-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on parse-server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-7m6r-fhh7-r47c (OSV record GHSA-7m6r-fhh7-r47c lists affected ranges: npm parse-server >=9.0.0-alpha.1 =0 <8.6.26 (fixed)) - Verified: https://github.com/advisories/GHSA-7m6r-fhh7-r47c (GitHub-reviewed advisory GHSA-7m6r-fhh7-r47c lists affected ranges: npm parse-server >=9.0.0-alpha.1 =0 <8.6.26) Commands are suggestions: review each one before running it.
Loading voting…