pypdf: manipulated stream length values can exhaust RAM
CVE-2026-31826GHSA-hqmh-ppp3-xvm7
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (pypdf 6.8.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI pypdf
- Affected
- < 6.8.0
- Fixed in
- 6.8.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-hqmh-ppp3-xvm7 lists affected ranges: PyPI pypdf >=0 <6.8.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-hqmh-ppp3-xvm7 lists affected ranges: PyPI pypdf >=0 <6.8.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.8 · CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-31826: 0.18% estimated exploitation activity in the next 30 days; percentile 7.92 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact An attacker who uses this vulnerability can craft a PDF which leads to large memory usage. This requires parsing a content stream with a rather large /Length value, regardless of the actual data length inside the stream. Patches This has been fixed in pypdf==6.8.0. Workarounds If you cannot upgrade yet, consider applying the changes from PR #3675. As far as we are aware, this mostly affects reading from buffers of unknown size, as returned by open("file.pdf", mode="rb") for example. Passing a file path or a BytesIO buffer to pypdf instead does not seem to trigger the vulnerability.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-hqmh-ppp3-xvm7
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-hqmh-ppp3-xvm7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-31826 Advisory: pypdf: manipulated stream length values can exhaust RAM IDs: CVE-2026-31826, GHSA-hqmh-ppp3-xvm7 Record: https://patchnext.com/advisories/cve-2026-31826 (revision 3, source checked 26 Oct 2026, 13:37 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: pypdf 6.8.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI pypdf: affected < 6.8.0; fixed in 6.8.0 ## Suggested inspection (read-only) - `python -m pip show pypdf`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on pypdf. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-hqmh-ppp3-xvm7 (OSV record GHSA-hqmh-ppp3-xvm7 lists affected ranges: PyPI pypdf >=0 <6.8.0 (fixed)) - Verified: https://github.com/advisories/GHSA-hqmh-ppp3-xvm7 (GitHub-reviewed advisory GHSA-hqmh-ppp3-xvm7 lists affected ranges: PyPI pypdf >=0 <6.8.0) Commands are suggestions: review each one before running it.
Loading voting…