Sylius has a XSS vulnerability in checkout login form
CVE-2026-31822GHSA-vgh8-c6fp-7gcg
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (sylius/sylius 2.2.3, 2.1.12, 2.0.16), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist sylius/sylius
- Affected
- >= 2.0.0, <= 2.0.15>= 2.1.0, <= 2.1.11>= 2.2.0, <= 2.2.2
- Fixed in
- 2.1.12, 2.0.16, 2.2.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vgh8-c6fp-7gcg lists affected ranges: Packagist sylius/sylius >=2.0.0 =2.1.0 =2.2.0 <=2.2.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N · score source
- EPSS
- CVE-2026-31822: 0.19% estimated exploitation activity in the next 30 days; percentile 8.78 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A cross-site scripting (XSS) vulnerability exists in the shop checkout login form handled by the ApiLoginController Stimulus controller. When a login attempt fails, AuthenticationFailureHandler returns a JSON response whose message field is rendered into the DOM using innerHTML, allowing any HTML or JavaScript in that value to be parsed and executed by the browser. The message value originates from AuthenticationException::getMessageKey() passed through Symfony's translator (security domain, using the request locale). In the default Sylius installation, this returns a hardcoded translation key (e.g. "Invalid credentials."), which is not directly user-controlled. However, using innerHTML with server-derived data violates defense-in-depth principles, and the risk escalates significantly under realistic scenarios: - Customized authentication handlers — if a project overrides AuthenticationFailureHandler to include user-supplied data in the message (e.g. "No account found for…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-vgh8-c6fp-7gcg
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-31822 Advisory: Sylius has a XSS vulnerability in checkout login form IDs: CVE-2026-31822, GHSA-vgh8-c6fp-7gcg Record: https://patchnext.com/advisories/cve-2026-31822 (revision 1, source checked 26 Oct 2026, 14:38 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: sylius/sylius 2.2.3, 2.1.12, 2.0.16. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist sylius/sylius: affected >= 2.0.0, <= 2.0.15; >= 2.1.0, <= 2.1.11; >= 2.2.0, <= 2.2.2; fixed in 2.1.12, 2.0.16, 2.2.3 ## Suggested inspection (read-only) - Packagist sylius/sylius: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on sylius/sylius. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-vgh8-c6fp-7gcg (GitHub-reviewed advisory GHSA-vgh8-c6fp-7gcg lists affected ranges: Packagist sylius/sylius >=2.0.0 =2.1.0 =2.2.0 <=2.2.2) Commands are suggestions: review each one before running it.
Loading voting…