Skip to content

← Actionable
Medium, CVSS 6.9

Sylius is Missing Authorization in API v2 Add Item Endpoint

CVE-2026-31821GHSA-wjmg-4cq5-m8hg

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (sylius/sylius 2.2.3, 2.1.12, 2.0.16), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist sylius/sylius

    Affected
    >= 2.0.0, <= 2.0.15>= 2.1.0, <= 2.1.11>= 2.2.0, <= 2.2.2
    Fixed in
    2.1.12, 2.0.16, 2.2.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-31821: 0.19% estimated exploitation activity in the next 30 days; percentile 9.02 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The POST /api/v2/shop/orders/{tokenValue}/items endpoint does not verify cart ownership. An unauthenticated attacker can add items to other registered customers' carts by knowing the cart tokenValue. Other mutation endpoints (PUT, PATCH, DELETE) are not affected. API Platform loads the Order entity through the state provider for these operations, which triggers VisitorBasedExtension and returns 404 for unauthorized users. An attacker who obtains a cart tokenValue can add arbitrary items to another customer's cart. The endpoint returns the full cart representation in the response (HTTP 201), potentially leaking: - Customer email address - Cart contents (products, quantities, prices) - Address data (billing and shipping if set) - Payment and shipment IDs - Order totals and tax breakdown - Checkout state Patches The issue is fixed in versions: 2.0.16, 2.1.12, 2.2.3, and above. Workarounds Add an ownership check in AddItemToCartHandler by injecting UserContextInterface and…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-wjmg-4cq5-m8hg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-31821

Advisory: Sylius is Missing Authorization in API v2 Add Item Endpoint
IDs: CVE-2026-31821, GHSA-wjmg-4cq5-m8hg
Record: https://patchnext.com/advisories/cve-2026-31821 (revision 1, source checked 26 Oct 2026, 14:38 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: sylius/sylius 2.2.3, 2.1.12, 2.0.16. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist sylius/sylius: affected >= 2.0.0, <= 2.0.15; >= 2.1.0, <= 2.1.11; >= 2.2.0, <= 2.2.2; fixed in 2.1.12, 2.0.16, 2.2.3

## Suggested inspection (read-only)
- Packagist sylius/sylius: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on sylius/sylius.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-wjmg-4cq5-m8hg (GitHub-reviewed advisory GHSA-wjmg-4cq5-m8hg lists affected ranges: Packagist sylius/sylius >=2.0.0 =2.1.0 =2.2.0 <=2.2.2)

Commands are suggestions: review each one before running it.

Loading voting…