Skip to content

← Actionable
Medium, CVSS 6.9

Sylius has an Open Redirect via Referer Header

CVE-2026-31819GHSA-9ffx-f77r-756w

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (sylius/sylius 2.2.3, 2.1.12, 2.0.16, 1.14.18, 1.13.15, 1.12.23, 1.11.17, 1.10.16, 1.9.12), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist sylius/sylius

    Affected
    <= 1.9.11>= 1.10.0, <= 1.10.15>= 1.11.0, <= 1.11.16>= 1.12.0, <= 1.12.22>= 1.13.0, <= 1.13.14>= 1.14.0, <= 1.14.17>= 2.0.0, <= 2.0.15>= 2.1.0, <= 2.1.11>= 2.2.0, <= 2.2.2
    Fixed in
    1.10.16, 2.1.12, 1.11.17, 1.14.18, 1.12.23, 2.0.16, 1.13.15, 2.2.3, 1.9.12

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-9ffx-f77r-756w lists affected ranges: Packagist sylius/sylius >=0 =1.10.0 =1.11.0 =1.12.0 =1.13.0 =1.14.0 =2.0.0 =2.1.0 =2.2.0 <=2.2.2

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:L/SI:L/SA:L · score source
EPSS
  • CVE-2026-31819: 0.18% estimated exploitation activity in the next 30 days; percentile 7.94 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact CurrencySwitchController::switchAction(), ImpersonateUserController::impersonateAction() and StorageBasedLocaleSwitcher::handle() use the HTTP Referer header directly when redirecting. The attack requires the victim to click a legitimate application link placed on an attacker-controlled page. The browser automatically sends the attacker's site as the Referer, and the application redirects back to it. This can be used for phishing or credential theft, as the redirect originates from a trusted domain. The severity varies by endpoint; public endpoints require no authentication and are trivially exploitable, while admin-only endpoints require an authenticated session but remain vulnerable if an admin follows a link from an external source such as email or chat. Affected classes: - CurrencySwitchController::switchAction() - public - StorageBasedLocaleSwitcher::handle() - public, used in locale switching without having locale in the url -…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-9ffx-f77r-756w

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-31819

Advisory: Sylius has an Open Redirect via Referer Header
IDs: CVE-2026-31819, GHSA-9ffx-f77r-756w
Record: https://patchnext.com/advisories/cve-2026-31819 (revision 1, source checked 26 Oct 2026, 14:38 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: sylius/sylius 2.2.3, 2.1.12, 2.0.16, 1.14.18, 1.13.15, 1.12.23, 1.11.17, 1.10.16, 1.9.12. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist sylius/sylius: affected <= 1.9.11; >= 1.10.0, <= 1.10.15; >= 1.11.0, <= 1.11.16; >= 1.12.0, <= 1.12.22; >= 1.13.0, <= 1.13.14; >= 1.14.0, <= 1.14.17; >= 2.0.0, <= 2.0.15; >= 2.1.0, <= 2.1.11; >= 2.2.0, <= 2.2.2; fixed in 1.10.16, 2.1.12, 1.11.17, 1.14.18, 1.12.23, 2.0.16, 1.13.15, 2.2.3, 1.9.12

## Suggested inspection (read-only)
- Packagist sylius/sylius: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on sylius/sylius.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-9ffx-f77r-756w (GitHub-reviewed advisory GHSA-9ffx-f77r-756w lists affected ranges: Packagist sylius/sylius >=0 =1.10.0 =1.11.0 =1.12.0 =1.13.0 =1.14.0 =2.0.0 =2.1.0 =2.2.0 <=2.2.2)

Commands are suggestions: review each one before running it.

Loading voting…