Skip to content

← Actionable
Critical, CVSS 9.6amended

Budibase: Server-Side Request Forgery via REST Connector with Empty Default Blacklist

CVE-2026-31818GHSA-7r9j-r86q-7g45

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@budibase/backend-core 3.33.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.6 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:N
EPSS
  • CVE-2026-31818: 0.38% estimated exploitation activity in the next 30 days; percentile 32.44 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

1. Summary | Field | Value | |-------|-------| | Title | SSRF via REST Connector with Empty Default Blacklist Leading to Full Internal Data Exfiltration | | Product | Budibase | | Version | 3.30.6 (latest stable as of 2026-02-25) | | Component | REST Datasource Integration + Backend-Core Blacklist Module | | Severity | Critical | | Attack Vector | Network | | Privileges Required | Low (Builder role, or QUERY WRITE for execution of pre-existing queries) | | User Interaction | None | | Affected Deployments | All self-hosted instances without explicit BLACKLISTIPS configuration (believed to be the vast majority) | --- 2. Description A critical Server-Side Request Forgery (SSRF) vulnerability exists in Budibase's REST datasource connector. The platform's SSRF protection mechanism (IP blacklist) is rendered completely ineffective because the BLACKLISTIPS environment variable is not set by default in any of the official deployment configurations. When this variable is empty, the blacklist…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-7r9j-r86q-7g45

  2. Revision 2 · amended ·

    Amended from osv record GHSA-7r9j-r86q-7g45

  3. Revision 1 · created ·

    Published from ghsa record GHSA-7r9j-r86q-7g45

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-31818

Advisory: Budibase: Server-Side Request Forgery via REST Connector with Empty Default Blacklist
IDs: CVE-2026-31818, GHSA-7r9j-r86q-7g45
Record: https://patchnext.com/advisories/cve-2026-31818 (revision 3, source checked 26 Oct 2026, 12:47 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @budibase/backend-core 3.33.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @budibase/backend-core: affected < 3.33.4; fixed in 3.33.4

## Suggested inspection (read-only)
- `npm ls @budibase/backend-core --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @budibase/backend-core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-7r9j-r86q-7g45 (GitHub-reviewed advisory GHSA-7r9j-r86q-7g45 lists affected ranges: npm @budibase/backend-core >=0 <3.33.4)
- Verified: https://osv.dev/vulnerability/GHSA-7r9j-r86q-7g45 (OSV record GHSA-7r9j-r86q-7g45 lists affected ranges: npm @budibase/backend-core >=0 <3.33.4 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…