Skip to content

← Actionable
Medium, CVSS 5.3amended

file-type affected by infinite loop in ASF parser on malformed input with zero-size sub-header

CVE-2026-31808GHSA-5v7r-6r5c-r473

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (file-type 21.3.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm file-type

    Affected
    >= 13.0.0, < 21.3.1
    Fixed in
    21.3.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
EPSS
  • CVE-2026-31808: 0.34% estimated exploitation activity in the next 30 days; percentile 28.09 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A denial of service vulnerability exists in the ASF (WMV/WMA) file type detection parser. When parsing a crafted input where an ASF sub-header has a size field of zero, the parser enters an infinite loop. The payload value becomes negative (-24), causing tokenizer.ignore(payload) to move the read position backwards, so the same sub-header is read repeatedly forever. Any application that uses file-type to detect the type of untrusted/attacker-controlled input is affected. An attacker can stall the Node.js event loop with a 55-byte payload. Patches Fixed in version 21.3.1. Users should upgrade to = 21.3.1. Workarounds Validate or limit the size of input buffers before passing them to file-type, or run file type detection in a worker thread with a timeout. References - Fix commit: 319abf871b50ba2fa221b4a7050059f1ae096f4f Reporter crnkovic@lokvica.com

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-5v7r-6r5c-r473

  2. Revision 1 · created ·

    Published from osv record GHSA-5v7r-6r5c-r473

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-31808

Advisory: file-type affected by infinite loop in ASF parser on malformed input with zero-size sub-header
IDs: CVE-2026-31808, GHSA-5v7r-6r5c-r473
Record: https://patchnext.com/advisories/cve-2026-31808 (revision 2, source checked 26 Oct 2026, 12:43 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: file-type 21.3.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm file-type: affected >= 13.0.0, < 21.3.1; fixed in 21.3.1

## Suggested inspection (read-only)
- `npm ls file-type --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on file-type.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-5v7r-6r5c-r473 (OSV record GHSA-5v7r-6r5c-r473 lists affected ranges: npm file-type >=13.0.0 <21.3.1 (fixed))
- Verified: https://github.com/advisories/GHSA-5v7r-6r5c-r473 (GitHub-reviewed advisory GHSA-5v7r-6r5c-r473 lists affected ranges: npm file-type >=13.0.0 <21.3.1)

Commands are suggestions: review each one before running it.

Loading voting…