Mattermost doesn't validate decompressed archive entry sizes during file extraction
CVE-2026-3114GHSA-vhgh-g7x8-4rx8
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/mattermost/mattermost/server/v8 11.4.1, 11.3.2, 11.2.4, 10.11.12, 8.0.0-20260217110922-b7d4a1f1f59b), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/mattermost/mattermost/server/v8
- Affected
- >= 11.4.0, <= 11.4.0>= 11.3.0, < 11.3.2>= 11.2.0, < 11.2.4>= 10.11.0, < 10.11.12>= 8.0.0-20260105080200-d27a2195068d, < 8.0.0-20260217110922-b7d4a1f1f59b
- Fixed in
- 8.0.0-20260217110922-b7d4a1f1f59b, 11.4.1, 11.3.2, 11.2.4, 10.11.12
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vhgh-g7x8-4rx8 lists affected ranges: Go github.com/mattermost/mattermost/server/v8 >=11.4.0 =11.3.0 =11.2.0 =10.11.0 =8.0.0-20260105080200-d27a2195068d <8.0.0-20260217110922-b7d4a1f1f59b
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2026-3114: 0.36% estimated exploitation activity in the next 30 days; percentile 29.38 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Mattermost versions 11.4.x <= 11.4.0, 11.3.x <= 11.3.1, 11.2.x <= 11.2.3, 10.11.x <= 10.11.11 fail to validate decompressed archive entry sizes during file extraction which allows authenticated users with file upload permissions to cause a denial of service via crafted zip archives containing highly compressed entries (zip bombs) that exhaust server memory. Mattermost Advisory ID: MMSA-2026-00598.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-vhgh-g7x8-4rx8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-3114 Advisory: Mattermost doesn't validate decompressed archive entry sizes during file extraction IDs: CVE-2026-3114, GHSA-vhgh-g7x8-4rx8 Record: https://patchnext.com/advisories/cve-2026-3114 (revision 1, source checked 26 Oct 2026, 15:19 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/mattermost/mattermost/server/v8 11.4.1, 11.3.2, 11.2.4, 10.11.12, 8.0.0-20260217110922-b7d4a1f1f59b. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/mattermost/mattermost/server/v8: affected >= 11.4.0, <= 11.4.0; >= 11.3.0, < 11.3.2; >= 11.2.0, < 11.2.4; >= 10.11.0, < 10.11.12; >= 8.0.0-20260105080200-d27a2195068d, < 8.0.0-20260217110922-b7d4a1f1f59b; fixed in 8.0.0-20260217110922-b7d4a1f1f59b, 11.4.1, 11.3.2, 11.2.4, 10.11.12 ## Suggested inspection (read-only) - Go github.com/mattermost/mattermost/server/v8: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/mattermost/mattermost/server/v8. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-vhgh-g7x8-4rx8 (GitHub-reviewed advisory GHSA-vhgh-g7x8-4rx8 lists affected ranges: Go github.com/mattermost/mattermost/server/v8 >=11.4.0 =11.3.0 =11.2.0 =10.11.0 =8.0.0-20260105080200-d27a2195068d <8.0.0-20260217110922-b7d4a1f1f59b) Commands are suggestions: review each one before running it.
Loading voting…