Mautic is Vulnerable to SQL Injection through Contact Activity API Sorting
CVE-2026-3105GHSA-r5j5-q42h-fc93
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (mautic/core 7.0.1, 6.0.8, 5.2.10), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist mautic/core
- Affected
- >= 2.10.0, < 5.2.10>= 6.0.0-alpha, < 6.0.8>= 7.0.0-alpha, < 7.0.1
- Fixed in
- 6.0.8, 5.2.10, 7.0.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-r5j5-q42h-fc93 lists affected ranges: Packagist mautic/core >=2.10.0 =6.0.0-alpha =7.0.0-alpha <7.0.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.6 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:L
- EPSS
- CVE-2026-3105: 0.33% estimated exploitation activity in the next 30 days; percentile 26.05 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary This advisory addresses a SQL Injection vulnerability in the API endpoint used for retrieving contact activities. A vulnerability exists in the query construction for the Contact Activity timeline where the parameter responsible for determining the sort direction was not strictly validated against an allowlist, potentially allowing authenticated users to inject arbitrary SQL commands via the API. Mitigation Please update to 5.2.10, 6.0.8, 7.0.1 or later. Workarounds None. References If there are any questions or comments about this advisory: Email Mautic at security@mautic.org
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-r5j5-q42h-fc93
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-3105 Advisory: Mautic is Vulnerable to SQL Injection through Contact Activity API Sorting IDs: CVE-2026-3105, GHSA-r5j5-q42h-fc93 Record: https://patchnext.com/advisories/cve-2026-3105 (revision 1, source checked 26 Oct 2026, 14:38 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: mautic/core 7.0.1, 6.0.8, 5.2.10. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist mautic/core: affected >= 2.10.0, < 5.2.10; >= 6.0.0-alpha, < 6.0.8; >= 7.0.0-alpha, < 7.0.1; fixed in 6.0.8, 5.2.10, 7.0.1 ## Suggested inspection (read-only) - Packagist mautic/core: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on mautic/core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-r5j5-q42h-fc93 (GitHub-reviewed advisory GHSA-r5j5-q42h-fc93 lists affected ranges: Packagist mautic/core >=2.10.0 =6.0.0-alpha =7.0.0-alpha <7.0.1) Commands are suggestions: review each one before running it.
Loading voting…