copyparty: volflag nohtml did not block javascript in svg files
CVE-2026-30974GHSA-m6hv-x64c-27mm
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (copyparty 1.20.11), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI copyparty
- Affected
- <= 1.20.10
- Fixed in
- 1.20.11
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-m6hv-x64c-27mm lists affected ranges: PyPI copyparty >=0 <1.20.11 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-m6hv-x64c-27mm lists affected ranges: PyPI copyparty >=0 <=1.20.10
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.6 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:N
- EPSS
- CVE-2026-30974: 0.34% estimated exploitation activity in the next 30 days; percentile 27.88 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The nohtml config option, intended to prevent execution of JavaScript in user-uploaded HTML files, did not apply to SVG images. Details A user with write-permission could upload an SVG containing embedded JavaScript, which would execute in the context of whichever user opens it. This in itself is not a vulnerability; it is intended behavior according to the SVG spec. The vulnerability is that the nohtml volflag, when enabled, did not prevent this. nohtml, intended for use on volumes which contains untrusted files, would correctly prevent execution of javascript in HTML files, but did not consider SVG images. This has been fixed in v1.20.11. Impact The malicious JavaScript could move or delete existing files on the server, or upload new files, using the account of the person who opens the SVG.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-m6hv-x64c-27mm
- Revision 1 · created ·
Published from osv record GHSA-m6hv-x64c-27mm
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-30974 Advisory: copyparty: volflag `nohtml` did not block javascript in svg files IDs: CVE-2026-30974, GHSA-m6hv-x64c-27mm Record: https://patchnext.com/advisories/cve-2026-30974 (revision 2, source checked 26 Oct 2026, 13:37 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: copyparty 1.20.11. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI copyparty: affected <= 1.20.10; fixed in 1.20.11 ## Suggested inspection (read-only) - `python -m pip show copyparty`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on copyparty. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-m6hv-x64c-27mm (OSV record GHSA-m6hv-x64c-27mm lists affected ranges: PyPI copyparty >=0 <1.20.11 (fixed)) - Verified: https://github.com/advisories/GHSA-m6hv-x64c-27mm (GitHub-reviewed advisory GHSA-m6hv-x64c-27mm lists affected ranges: PyPI copyparty >=0 <=1.20.10) Commands are suggestions: review each one before running it.
Loading voting…