@appium/support has a Zip Slip arbitrary file write in its ZIP extraction
CVE-2026-30973GHSA-rfx7-4xw3-gh4m
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@appium/support 7.0.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @appium/support
- Affected
- <= 7.0.5
- Fixed in
- 7.0.6
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-rfx7-4xw3-gh4m lists affected ranges: npm @appium/support >=0 <7.0.6 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-rfx7-4xw3-gh4m lists affected ranges: npm @appium/support >=0 <=7.0.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N
- EPSS
- CVE-2026-30973: 0.44% estimated exploitation activity in the next 30 days; percentile 38.40 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary @appium/support contains a ZIP extraction implementation (extractAllTo() via ZipExtractor.extract()) with a path traversal (Zip Slip) check that is non-functional. The check at line 88 of packages/support/lib/zip.js creates an Error object but never throws it, allowing malicious ZIP entries with ../ path components to write files outside the intended destination directory. This affects all JS-based extractions (the default code path), not only those using the fileNamesEncoding option. Severity Medium (CVSS 3.1: 6.5) CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N - Attack Vector: Network — malicious ZIP files can be supplied over the network (e.g., app packages via URL) - Attack Complexity: Low — no special conditions required beyond providing a crafted ZIP - Privileges Required: None — no authentication needed to supply a malicious archive - User Interaction: Required — a user or automation system must initiate extraction of the attacker's archive - Scope: Unchanged — impact…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-rfx7-4xw3-gh4m
- Revision 1 · created ·
Published from osv record GHSA-rfx7-4xw3-gh4m
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-30973 Advisory: @appium/support has a Zip Slip arbitrary file write in its ZIP extraction IDs: CVE-2026-30973, GHSA-rfx7-4xw3-gh4m Record: https://patchnext.com/advisories/cve-2026-30973 (revision 2, source checked 26 Oct 2026, 12:43 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @appium/support 7.0.6. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @appium/support: affected <= 7.0.5; fixed in 7.0.6 ## Suggested inspection (read-only) - `npm ls @appium/support --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @appium/support. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-rfx7-4xw3-gh4m (OSV record GHSA-rfx7-4xw3-gh4m lists affected ranges: npm @appium/support >=0 <7.0.6 (fixed)) - Verified: https://github.com/advisories/GHSA-rfx7-4xw3-gh4m (GitHub-reviewed advisory GHSA-rfx7-4xw3-gh4m lists affected ranges: npm @appium/support >=0 <=7.0.5) Commands are suggestions: review each one before running it.
Loading voting…