Parse Server OAuth2 authentication adapter account takeover via identity spoofing
CVE-2026-30967GHSA-fr88-w35c-r596
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (parse-server 9.5.2-alpha.9, 8.6.22), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm parse-server
- Affected
- >= 9.0.0-alpha.1, < 9.5.2-alpha.9< 8.6.22
- Fixed in
- 9.5.2-alpha.9, 8.6.22
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-fr88-w35c-r596 lists affected ranges: npm parse-server >=9.0.0-alpha.1 =0 <8.6.22 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-fr88-w35c-r596 lists affected ranges: npm parse-server >=9.0.0-alpha.1 =0 <8.6.22
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.6 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-30967: 0.35% estimated exploitation activity in the next 30 days; percentile 29.11 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The OAuth2 authentication adapter, when configured without the useridField option, only verifies that a token is active via the provider's token introspection endpoint, but does not verify that the token belongs to the user identified by authData.id. An attacker with any valid OAuth2 token from the same provider can authenticate as any other user. This affects any Parse Server deployment that uses the generic OAuth2 authentication adapter (configured with oauth2: true) without setting the useridField option. Patches The vulnerability is fixed by defaulting useridField to sub, which is the standard subject identifier field defined by RFC 7662. The adapter now always validates the token's identity against the claimed user ID, even when useridField is not explicitly configured. Workarounds Set the useridField option to the appropriate field name for your OAuth2 provider (e.g. sub) in the Parse Server authentication configuration. References - GitHub security advisory:…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-fr88-w35c-r596
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-fr88-w35c-r596
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-30967 Advisory: Parse Server OAuth2 authentication adapter account takeover via identity spoofing IDs: CVE-2026-30967, GHSA-fr88-w35c-r596 Record: https://patchnext.com/advisories/cve-2026-30967 (revision 3, source checked 26 Oct 2026, 12:43 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: parse-server 9.5.2-alpha.9, 8.6.22. A vendor fix does not mean a deployment is fixed. ## Affected components - npm parse-server: affected >= 9.0.0-alpha.1, < 9.5.2-alpha.9; < 8.6.22; fixed in 9.5.2-alpha.9, 8.6.22 ## Suggested inspection (read-only) - `npm ls parse-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on parse-server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-fr88-w35c-r596 (OSV record GHSA-fr88-w35c-r596 lists affected ranges: npm parse-server >=9.0.0-alpha.1 =0 <8.6.22 (fixed)) - Verified: https://github.com/advisories/GHSA-fr88-w35c-r596 (GitHub-reviewed advisory GHSA-fr88-w35c-r596 lists affected ranges: npm parse-server >=9.0.0-alpha.1 =0 <8.6.22) Commands are suggestions: review each one before running it.
Loading voting…