Skip to content

← Actionable
Critical, CVSS 9.9amended

Parse Server vulnerable to session token exfiltration via redirectClassNameForKey query parameter

CVE-2026-30965GHSA-6r2j-cxgf-495f

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (parse-server 9.5.2-alpha.8, 8.6.21), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm parse-server

    Affected
    >= 9.0.0-alpha.1, < 9.5.2-alpha.8< 8.6.21
    Fixed in
    8.6.21, 9.5.2-alpha.8

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:H/SI:H/SA:N · score source
EPSS
  • CVE-2026-30965: 1.36% estimated exploitation activity in the next 30 days; percentile 71.72 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A vulnerability in Parse Server's query handling allows an authenticated or unauthenticated attacker to exfiltrate session tokens of other users by exploiting the redirectClassNameForKey query parameter. Exfiltrated session tokens can be used to take over user accounts. The vulnerability requires the attacker to be able to create or update an object with a new relation field, which depends on the Class-Level Permissions of at least one class. Patches The fix applies the same security checks that normally protect class access after the query redirect, ensuring that queries redirected via redirectClassNameForKey are subject to the same restrictions as direct queries to the target class. Workarounds Set restrictive Class-Level Permissions to prevent clients from creating new fields on classes, specifically by disabling addField for public access and unauthenticated users. Note that this limits client functionality and does not fully eliminate the risk if a relation field pointing…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-6r2j-cxgf-495f

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GHSA-6r2j-cxgf-495f

  4. Revision 1 · created ·

    Published from ghsa record GHSA-6r2j-cxgf-495f

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-30965

Advisory: Parse Server vulnerable to session token exfiltration via `redirectClassNameForKey` query parameter
IDs: CVE-2026-30965, GHSA-6r2j-cxgf-495f
Record: https://patchnext.com/advisories/cve-2026-30965 (revision 4, source checked 26 Oct 2026, 12:43 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: parse-server 9.5.2-alpha.8, 8.6.21. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm parse-server: affected >= 9.0.0-alpha.1, < 9.5.2-alpha.8; < 8.6.21; fixed in 8.6.21, 9.5.2-alpha.8

## Suggested inspection (read-only)
- `npm ls parse-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on parse-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-6r2j-cxgf-495f (GitHub-reviewed advisory GHSA-6r2j-cxgf-495f lists affected ranges: npm parse-server >=9.0.0-alpha.1 =0 <8.6.21)
- Verified: https://osv.dev/vulnerability/GHSA-6r2j-cxgf-495f (OSV record GHSA-6r2j-cxgf-495f lists affected ranges: npm parse-server >=9.0.0-alpha.1 =0 <8.6.21 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…