Webauthn Framework: allowed_origins collapses URL-like origins to host-only values, bypassing exact origin validation
CVE-2026-30964GHSA-f7pm-6hr8-7ggm
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (web-auth/webauthn-symfony-bundle 5.2.4; web-auth/webauthn-lib 5.2.4; web-auth/webauthn-framework 5.2.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist web-auth/webauthn-symfony-bundle
- Affected
- >= 5.2.0, < 5.2.4
- Fixed in
- 5.2.4
Packagist web-auth/webauthn-lib
- Affected
- >= 5.2.0, < 5.2.4
- Fixed in
- 5.2.4
Packagist web-auth/webauthn-framework
- Affected
- >= 5.2.0, < 5.2.4
- Fixed in
- 5.2.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-f7pm-6hr8-7ggm lists affected ranges: Packagist web-auth/webauthn-framework >=5.2.0 =5.2.0 =5.2.0 <5.2.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.4 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N
- EPSS
- CVE-2026-30964: 0.21% estimated exploitation activity in the next 30 days; percentile 11.13 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary When allowedorigins is configured, CheckAllowedOrigins reduces URL-like values to their host component and accepts on host match alone. This makes exact origin policies impossible to express: scheme and port differences are silently ignored. Details CheckAllowedOrigins stores each configured allowed origin as: and later reduces the received clientDataJSON.origin the same way: If the reduced value matches, the method returns early. As a result, for the normal allowedorigins path, the later HTTPS check is not reached. This differs from WebAuthn Level 2, which requires verifying that C.origin matches the RP's origin (scheme + host + port), separately from verifying that authData.rpIdHash matches the expected RP ID. Affected code: - CheckAllowedOrigins.php Spec references: - §7.1 Registering a New Credential - §7.2 Verifying an Authentication Assertion - CollectedClientData.origin PoC Configuration: Send a registration or authentication response whose clientDataJSON.origin is:…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-f7pm-6hr8-7ggm
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-30964 Advisory: Webauthn Framework: allowed_origins collapses URL-like origins to host-only values, bypassing exact origin validation IDs: CVE-2026-30964, GHSA-f7pm-6hr8-7ggm Record: https://patchnext.com/advisories/cve-2026-30964 (revision 1, source checked 26 Oct 2026, 14:38 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: web-auth/webauthn-symfony-bundle 5.2.4; web-auth/webauthn-lib 5.2.4; web-auth/webauthn-framework 5.2.4. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist web-auth/webauthn-symfony-bundle: affected >= 5.2.0, < 5.2.4; fixed in 5.2.4 - Packagist web-auth/webauthn-lib: affected >= 5.2.0, < 5.2.4; fixed in 5.2.4 - Packagist web-auth/webauthn-framework: affected >= 5.2.0, < 5.2.4; fixed in 5.2.4 ## Suggested inspection (read-only) - Packagist web-auth/webauthn-symfony-bundle: check the installed version with your package manager. - Packagist web-auth/webauthn-lib: check the installed version with your package manager. - Packagist web-auth/webauthn-framework: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on web-auth/webauthn-symfony-bundle, web-auth/webauthn-lib, web-auth/webauthn-framework. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-f7pm-6hr8-7ggm (GitHub-reviewed advisory GHSA-f7pm-6hr8-7ggm lists affected ranges: Packagist web-auth/webauthn-framework >=5.2.0 =5.2.0 =5.2.0 <5.2.4) Commands are suggestions: review each one before running it.
Loading voting…